HDU 1316 How Many Fibs?

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1316

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4539    Accepted Submission(s): 1784


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
 
求指定区间的斐波那契数的个数

先打表,然后直接统计就行了,区间比较小,不需要二分。难度中等

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=1005,maxe=1005,inf=1<<29;
int a[maxe][maxn]={0},n;
char b[maxe][maxn];
char l[maxn],r[maxn];
void add()
{
    a[1][0]=1;a[2][0]=2;
    for(int i=3;i<maxe;i++)
        for(int j=0;j<maxn;j++)
            a[i][j]+=a[i-1][j]+a[i-2][j],a[i][j+1]+=a[i][j]/10,a[i][j]%=10;
    memset(b,0,sizeof(b));
    for(int i=1;i<maxe;i++)
    {
        int l=maxn-1,j=0;
        while(!a[i][l]) l--;
        while(l>=0) b[i][j++]=a[i][l--]+'0';
    }
}
int main()
{
    add();//打表
    while(~scanf("%s%s",l,r)&&(l[0]!='0'||r[0]!='0'))
    {
        int ans=0,p=0;
        while(strlen(b[p])<strlen(l)||(strlen(b[p])==strlen(l)&&strcmp(b[p],l)<0)) p++;//找到第一个比左区间大的斐波数
        while(strlen(b[p])<strlen(r)||(strlen(b[p])==strlen(r)&&strcmp(b[p],r)<=0)) p++,ans++;//统计直到区间结束
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值