HDU 2925 Musical Chairs

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2925

Musical Chairs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1007    Accepted Submission(s): 576


Problem Description
In the traditional game of Musical Chairs, N + 1 children run around N chairs (placed in a circle) as long as music is playing. The moment the music stops, children run and try to sit on an available chair. The child still standing leaves the game, a chair is removed, and the game continues with N children. The last child to sit is the winner.

In an attempt to create a similar game on these days' game consoles, you modify the game in the following manner: N Children are seated on N chairs arranged around a circle. The chairs are numbered from 1 to N . Your program pre-selects a positive number D . The program starts going in circles counting the children starting with the first chair. Once the count reaches D , that child leaves the game, removing his/her chair. The program starts counting again, beginning with the next chair in the circle. The last child remaining in the circle is the winner.


For example, consider the game illustrated in the figure above for N = 5 and D = 3 . In the figure, the dot indicates where counting starts and × indicates the child leaving. Starting off, child #3 leaves the game, and counting restarts with child #4. Child #1 is the second child to leave and counting restart with child #2 resulting in child #5 leaving. Child #2 is the last to leave, and child #4 is the winner. Write a program to determine the winning child given both N and D .
 

Input
Your program will be tested on one or more test cases. Each test case specifies two positive integers N and D on a single line, separated by one or more spaces, where N, D < 1, 000, 000 .

The last line of the input file contains two 0's and is not part of the test cases.
 

Output
For each test case, write the winner using the following format:


N D W


Where N and D are as above, is a space character, and W is the winner of that game.
 

Sample Input
  
  
5 3 7 4 0 0
 

Sample Output
  
  
5 3 4 7 4 2
 
经典的约瑟夫模板题

为了讨论方便,先把问题稍微改变一下,并不影响原意:
问题描述:n个人(编号0~(n-1)),从0开始报数,报到m-1的退出
,剩下的人继续从0开始报数。求胜利者的编号。
我们知道第一个人(编号一定是(m-1)%n) 出列之后,剩下的n-1个人组成了一个新的约瑟夫环(以编号为k=m%n的人开始):
k k+1 k+2 ... n-2,n-1,0,1,2,... k-2
并且从k开始报0。
现在我们把他们的编号做一下转换:
k --> 0
k+1 --> 1
k+2 --> 2
...
...
k-3 --> n-3
k-2 --> n-2
序列1:0,1,2,3 … n-2,n-1
序列2:0,1,2,3 … k-2,k,…,n-2,n-1
序列3:k,k+1,k+2,k+3,…,n-2,n-1,0,1,2,3,…,k-2,
序列4:0,1,2,3 …,5,6,7,8,…,n-3,n-2
变换后就完完全全成为了(n-1)个人报数的子问题,假如我们知道这个子问题的解:例如x是最终的胜利者,那么根据上面这个表把这个x变回去不刚好就是n个人情况的解吗?!!变回去的公式很简单,相信大家都可以推出来,比如n-1个人最后胜利者的编号是序列4中的1,那么,显然它对应k+1,即原来的位置等于现在的位置+k:
∵ k=m%n;
∴ x' = x+k = x+ m%n ; 而 x+ m%n 可能大于n
∴x'= (x+ m%n)%n = (x+m)%n
得到 x‘=(x+m)%n
如何知道(n-1)个人报数的问题的解?对,只要知道(n-2)个人的解就行了。(n-2)个人的解呢?当然是先求(n-3)的情况 ---- 这显然就是一个倒推问题!好了,思路出来了,下面写递推公式:
令f表示i个人玩游戏报m退出最后胜利者的编号,最后的结果自然是f[n].
递推公式:
f[1]=0;
f[i]=(f[i-1]+m)%i; (i>1)
有了这个公式,我们要做的就是从1-n顺序算出f的数值,最后结果是f[n]。因为实际生活中编号总是从1开始,我们输出f[n]+1。
我们输出f[n]由于是逐级递推,不需要保存每个,程序也是异常简单:(注意编号是0 -- n-1)

我们可以写出递归程序(光是看别人的分析没有深刻理解是写不出来递归程序的,下面我会解释为何大家的程序都没有采用递归程序)

#include<cstdio>
int m;
int f(int n)
{
    if(n==1) return 0;
    int t=f(n-1);
    return (t+m)%n;
}
int main()
{
    int n;
    while(~scanf("%d%d",&n,&m)&&(n+m))
        printf("%d %d %d\n",n,m,f(n)+1);
    return 0;
}

显然这程序很简洁,你可以发现,例如要计算f(5),那么必须计算出f(4),f(3),,,,f(1),如果要计算f(n),n如果是1000000,那么这段程序是跑不动的,为什么么?程序是没有问题的,但是机器还不允许,硬件条件不够,因为递归要用到系统栈,而系统栈只有1一两兆哦。也是大家的题解没有采用递归的原因

显然,所以递归都可以转化为非递归。

下面是AC代码

#include<cstdio>
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=2,w=0;i<=n;i++) w=(w+m)%i;
        printf("%d %d %d\n",n,m,w+1);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值