HDU 1072 Nightmare

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1072

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7694    Accepted Submission(s): 3693


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13
0代表墙壁,1代表可以走的路,2代表起点,3代表终点。4代表时间重启装置。

规则,在炸弹开始计时后6秒未达到终点,即失败输出-1。在走的过程中,可借助时间重启装置来将炸弹的计时清零。每个点可走任意多次,每个装置可以使用任意多次。

这道题的难点在于如何标记。普通的标记方法是无效的,因为这里的点可以走任意多次,但是如果不标记的话,那在你没拓展到终点之前估计队列就爆掉了。那么,我们得想一种有效的标记方法。考虑到跟时间有关,那很容易想到在普通的二维标记数组再加个时间维度。

AC代码如下

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=105;
int Map[maxn][maxn];
bool vis[maxn][maxn][6];
struct node
{
    int x,y,s,t;
};
int n,m,sx,sy,ex,ey;
int dir[][2]={ {0,1},{-1,0},{0,-1},{1,0} };
int bfs()
{
    queue<node>q;
    node t={sx,sy,0,0};
    q.push(t);
    memset(vis,0,sizeof(vis));
    vis[sx][sy][0]=1;
    while(q.size())
    {
        t=q.front();q.pop();
        if(t.x==ex&&t.y==ey) return t.s;
        for(int i=0;i<4;i++)
        {
            int nx=t.x+dir[i][0],ny=t.y+dir[i][1];
            if(0<=nx&&nx<n&&0<=ny&&ny<m&&Map[nx][ny]!=0&&!vis[nx][ny][t.t+1]&&t.t<5)
            {
                vis[nx][ny][t.t+1]=1;
                if(Map[nx][ny]!=4) {node t1={nx,ny,t.s+1,t.t+1};q.push(t1);}
                else {node t1={nx,ny,t.s+1,0};q.push(t1);}
            }
        }
    }
    return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            scanf("%d",&Map[i][j]);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(Map[i][j]==2) sx=i,sy=j;
                else if(Map[i][j]==3) ex=i,ey=j;
            }
        cout<<bfs()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值