HDU 4499 Cannon

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4499

Cannon

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 518    Accepted Submission(s): 300


Problem Description
In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem.
An eat action, for example, Cannon A eating chessman B, requires two conditions:
1、A and B is in either the same row or the same column in the chess grid.
2、There is exactly one chessman between A and B.
Here comes the problem.
Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.
 

Input
There are multiple test cases.
In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen.
In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.
 

Output
There is only one line for each test case, containing the maximum number of cannons.
 

Sample Input
  
  
4 4 2 1 1 1 2 5 5 8 0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0
 

Sample Output
  
  
8 9
 

Source
此题乃是1045   Fire Net的 升级版

估计命题人也是根据这道题改编的吧。

/*题意:
给你一个棋盘,最大是5*5的,问你最多可以放多少个炮,炮和炮之间不可以相互攻击,
这块只的是只能走一步,不存在两个炮中间三个棋子的情况..

*/
做过1045就很容易解决这道题了,就是在判断合法性的时候稍微写写就OK了

下面是AC的代码

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=15;
int Map[maxn][maxn],n,m,q,ans;
bool judge(int x,int y)
{
    int i,j;
    for(i=x-1;i>=0;i--)
        if(Map[i][y]!=0) break;
    for(j=i-1;j>=0;j--)
        if(Map[j][y]==2) return 0;
        else if(Map[j][y]==1) break;
    for(i=y-1;i>=0;i--)
        if(Map[x][i]!=0) break;
    for(j=i-1;j>=0;j--)
        if(Map[x][j]==2) return 0;
        else if(Map[x][j]==1) break;
    return 1;
}
void dfs(int d,int cnt)
{
    if(d==n*m)
    {
        ans=max(ans,cnt);
        return ;
    }
    int x=d/m,y=d%m;
    if(judge(x,y)&&Map[x][y]==0)
    {
        Map[x][y]=2;
        dfs(d+1,cnt+1);
        Map[x][y]=0;
    }
    dfs(d+1,cnt);
}
int main()
{
    while(cin>>n>>m>>q)
    {
        memset(Map,0,sizeof(Map));
        while(q--)
        {
            int x,y;
            cin>>x>>y;
            Map[x][y]=1;
        }
        ans=0;
        dfs(0,0);
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值