poj2528 Mayor's posters(线段树+离散化)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42808 Accepted: 12481

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
/*
题目大意:贴海报,输入左右端点,问最多有多少不被覆盖,需要离散化,线段树题目做的少。。。。加油!!!
c++wa,g++过,不懂。。。。。
代码基本仿照的人家的
Time:2014-8-29 14:23
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson i<<1,l,mid
#define rson i<<1|1,mid+1,r
const int MAX=10000+10;
struct Poster{
	int l,r;
}p[MAX];
struct Node{//建立的映射 
	int l,r;
	bool bCovered;
}seg[MAX<<3];//因为每个点有两个端点,故需8倍
int nCount[MAX<<3]; 
int hash[10000000+10]; 
void Build(int i,int l,int r){
	seg[i].l=l;
	seg[i].r=r;
	seg[i].bCovered=false;
	if(seg[i].l==seg[i].r) return;
	
	int mid=(seg[i].l+seg[i].r)>>1;
	Build(lson);
	Build(rson);
}
bool Post(int i,int l,int r){
	if(seg[i].bCovered)return false;  //之前覆盖了, 
		
	if(seg[i].l==l&&seg[i].r==r){//之前未覆盖,本次覆盖的 
		seg[i].bCovered=true;
		return true;
	}
	bool bResult;
	int mid=(seg[i].l+seg[i].r)>>1;
	if(r<=mid){
		bResult=Post(i<<1,l,r);
	}else if(l>mid){
		bResult=Post(i<<1|1,l,r);
	}else{
		bool b1=Post(lson);
		bool b2=Post(rson);
		bResult=b1||b2;//不能直接拿Post运算,前边为真的时候就不运算了 
	}
	
	 if(seg[i<<1].bCovered&&seg[i<<1|1].bCovered)//如果左右子节点全被覆盖,则父节点也被覆盖了 
	 	seg[i].bCovered=true; //如果不这样处理,后边的访问到父节点直接返回了,不会访问子节点,会出错 
	
	return bResult;
} 
void solve(){
	int T;
	scanf("%d",&T);
	while(T--){
		int N,k=0;
		scanf("%d",&N);
		for(int i=0;i<N;i++){
			scanf("%d%d",&p[i].l,&p[i].r);
			nCount[k++]=p[i].l;
			nCount[k++]=p[i].r;
		}
		sort(nCount,nCount+k);
		k=unique(nCount,nCount+k)-nCount;//去重,unique返回尾地址
		for(int i=0;i<k;i++)
			hash[nCount[i]]=i;
		Build(1,0,k-1);//根节点应当从1开始,范围是0---k-1
		//若根节点从0 开始,则子节点应当是 2*i+1和2*i+2 
		int ans=0;
		for(int i=N-1;i>=0;i--){//这儿应当是N,不要写成k 
			if(Post(1,hash[p[i].l],hash[p[i].r]))
			//传入的是根节点和左右节点的映射,
			//从外向内贴,并判断是否被完全覆盖 
			ans++;
		}
		printf("%d\n",ans);
	}
}
int main(){
	solve();
return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值