NYOJ43 24 Point game(DFS)

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
/*
经典题,把用到的两个数记录下来,把结果放到后边的那一个数的位置上边。搜索的时候总是把没有用到的都会搜到,这样不会受括号影响,可以任意组合。以前感觉好难,没有做了,现在回头再看,有思路的话,也不是那么难,不过没想清楚,还是看人家的代码了。
加油!!!
Time:2014-9-16 15:50
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define eps 1e-6
double arr[10],tar;
bool vis[10];
int N;
double calculate(double a,double b,int c){//注意用double行,中间过程可能会得到小数
	switch(c){
		case 0:return a+b;
		case 1:return a-b;
		case 2:return a*b;
		case 3:return a/b;
		case 4:return b-a;
		case 5:return b/a;
	} 
}
bool DFS(int num,int pos){
	if(fabs(arr[pos]-tar)<=eps&&num==1)	return true;
	for(int i=1;i<=N;i++)if(!vis[i]){
		for(int j=i+1;j<=N;j++)if(!vis[j]){
			double temp1,temp2;
			for(int k=0;k<6;k++){
				temp1=arr[i];temp2=arr[j];
				if((temp1<=eps&&k==5)||(temp2<=eps&&k==3)) continue;
				vis[i]=true;
				arr[j]=calculate(temp1,temp2,k);//把求出来的放到后边数的那一位上,将前一位标记,相当于用三个数求 
				if(DFS(num-1,j)) return true;
				vis[i]=false;
				arr[i]=temp1;arr[j]=temp2;
			}
		}
	}
	return false;
}
void solve(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&N);
		scanf("%lf",&tar);
		for(int i=1;i<=N;i++){
			scanf("%lf",&arr[i]);
		}
		memset(vis,0,sizeof(vis));
		if(DFS(N,N)){
			printf("Yes\n");
		}else{
			printf("No\n");
		}
	}
}
int main(){
	solve();
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值