杭电4324 Triangle LOVE(拓扑排序)

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2582    Accepted Submission(s): 1050


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
/*
我怀疑题目有问题
直接拓扑排序有环就一定是三角环?我的深搜却出错 搞了我一下午,郁闷
加油!!!
Time:2014-10-12 16:54
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
bool map[2020][2020];
char s[2020];
int indegree[2020];
bool flag;
int N;
bool solve(){
	queue<int>q;
	for(int i=1;i<=N;i++){
		if(indegree[i]==0)
			q.push(i);
	}
	int num=0;
	while(!q.empty()){
		int cur=q.front();q.pop();
			num++;
		for(int i=1;i<=N;i++){
			if(map[cur][i]){
				indegree[i]--;
				if(indegree[i]==0){
					q.push(i);
				}
			}
		}
		
	}
	if(num==N)return false;//无环 
	return true;//有环 
}
int main(){
	int T;
	int ncase=0;	
	//freopen("hdu4324.txt","r",stdin);
	scanf("%d",&T);
	while(T--){
		scanf("%d",&N);
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		for(int i=1;i<=N;i++){
			scanf("%s",s);
			for(int j=1;j<=N;j++){
				map[i][j]=s[j-1]-'0';
				if(map[i][j])indegree[j]++;
			}
		}
		/*
		for(int i=1;i<=N;i++){
			for(int j=1;j<=N;j++)
			printf("%d ",map[i][j]);
			puts("");
		}*/
		if(solve())
			printf("Case #%d: Yes\n",++ncase);
		else
			printf("Case #%d: No\n",++ncase);
	}
return 0;
}
/*深搜wa
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
bool map[2020][2020];
int low[2020];
char s[2020];
bool flag;
int N;
void DFS(int x){
	if(flag) return;
	for(int i=1;i<=N;i++){
		if(map[x][i]){
			if(low[x]-low[i]==2){
				flag=1;
				return;	
			}
			else {
				low[i]=low[x]+1;
				DFS(i);
			}
		}
	}
}
void solve(){
	flag=0;
	for(int i=1;i<=N;i++){
		memset(low,0,sizeof(low));
			if(!flag)
			DFS(i);
	}
}
int main(){
	int T;
	int ncase=0;	
	//freopen("hdu4324.txt","r",stdin);
	scanf("%d",&T);
	while(T--){
		scanf("%d",&N);
		memset(map,0,sizeof(map));
		for(int i=1;i<=N;i++){
			scanf("%s",s);
			for(int j=1;j<=N;j++)
				map[i][j]=s[j-1]-'0';
		}
		/*
		for(int i=1;i<=N;i++){
			for(int j=1;j<=N;j++)
			printf("%d ",map[i][j]);
			puts("");
		}
		solve();
		if(flag)
			printf("Case #%d: Yes\n",++ncase);
		else
			printf("Case #%d: No\n",++ncase);
	}
return 0;
}
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值