杭电5120 Intersection(圆面积并)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 125    Accepted Submission(s): 51


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)  
/*环相交面积:A大环B大环相交面积-A大环B小环-B大环A小环+A小环B小环
正刚是直接套模板,我是直接套正刚的,哈哈
不过构造函数不知道怎么调用,再问一问。。。这个模板确实挺好的
加油!!!
Time:2014-11-30 11:38
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const double eps=1e-8;
const double PI=acos(-1.0);
int sign(double x){
	if(fabs(x)<eps) return 0;
	if(x<0) return -1;
	else return 1;
}
struct Point{
	double x,y;
	Point(){}
	Point(double _x,double _y):x(_x),y(_y){};//{x=_x;y=_y;}//
	Point operator -(const Point &b)const{//差 
		return Point(x-b.x,y-b.y);
	}
	double operator ^(const Point &b)const{//叉乘 
		return x*b.y-y*b.x;
	}
	double operator *(const Point &b)const{//点乘 
		return x*b.x+y*b.y;
	}
	void transXY(double B){//弧度逆时针旋转     旋转调用c1.transXY(弧度);即可
		double tx=x,ty=y;
		x=tx*cos(B)-ty*sin(B);
		y=tx*sin(B)+ty*cos(B);
	}
};
double dis(Point a,Point b){
	return sqrt((a-b)*(a-b));//-和*已经运算符重载 
}
double  Ac(Point c1,double r1,Point c2,double r2){//面积并 
	double d=dis(c1,c2);
	if(r1+r2<d+eps) return 0;//相离 
	if(d<fabs(r1-r2)+eps){//嵌套 
		double r=min(r1,r2);// 
		return PI*r*r;//小圆面积 
	}
	double x=(d*d+r1*r1-r2*r2)/(2*d);//余弦定理先除以2d,很巧妙 
	double t1=acos(x/r1);//如果除以r1则是左边的角度 
	double t2=acos((d-x)/r2);//用d-x一化简刚好除以r2是右边的角度 
	return r1*r1*t1+r2*r2*t2-d*r1*sin(t1);//两个弧的面积减去两个三角形的面积 
	//因为是全等三角形,相当于减去两圆心以及两圆交点形成的四边形 
}
int main(){
	int T;
	Point c1,c2;
	double ans,r,R,x1,x2,y1,y2;
	scanf("%d",&T);
	for(int i=1;i<=T;i++){
		scanf("%lf%lf%lf%lf%lf%lf",&r,&R,&x1,&y1,&x2,&y2);
		c1=Point(x1,y1);c2=Point(x2,y2);
		ans=Ac(c1,R,c2,R)-Ac(c1,r,c2,R)-Ac(c1,R,c2,r)+Ac(c1,r,c2,r);
		printf("Case #%d: %.6lf\n",i,ans); 
	}
return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值