杭电2841 Visible Trees(容斥原理第二题)

Visible Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1610    Accepted Submission(s): 664


Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
 

Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 

Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 

Sample Input
  
  
2 1 1 2 3
 

Sample Output
  
  
1 5
 

Source
2009 Multi-University Training Contest 3 - Host by WHU 
/*
题目大意:从1---n与1---m的矩阵,问从(0,0)点看,如果是一排只能看到第一个点,能看到多少个点,相当于所有点与(0,0)点连线,能得到多少条线。可知,lcm相当于斜率,当(x/lcm,y/lcm)时,不在一条线上
挺经典的,容斥原理,相当于求1---n与1---m的互质的点的个数  加油!!!
Time:2014-12-17 17:43
*/
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAX=100000+10;
vector<int>fac[MAX];
bool vis[MAX];
void Del(){
    memset(vis,0,sizeof(vis));
    for(int i=0;i<MAX;i++)fac[i].clear();

    for(int i=2;i<MAX;i++){
        if(!vis[i]){
                fac[i].push_back(i);
            for(int j=i+i;j<MAX;j+=i){
                    vis[j]=true;
                fac[j].push_back(i);
            }
        }
    }
}
LL Get_ans(int n,int m){
    LL cnt=0;
    int k=fac[n].size();
    int maxn=1<<k;
    for(int x=1;x<maxn;x++){
        int num=0,val=1;
        for(int i=0;i<k;i++){
            if(x&(1<<i)){
                num++;
                val*=fac[n][i];
            }
        }
        if(num&1)
            cnt+=m/val;
        else
            cnt-=m/val;
    }
    return m-cnt;
}
int main(){
    int T,n,m;
    Del();
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        if(n>m)swap(n,m);//后边是循环1<<m次,如果差的多话,可以减少很多循环次数
        LL ans=m;//注意:n=1时,有m个,不是n个
       for(int i=2;i<=n;i++)
            ans+=Get_ans(i,m);

        printf("%lld\n",ans);
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值