杭电2612 Find a way(BFS)

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4019    Accepted Submission(s): 1343


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 

Author
yifenfei
 

Source
附:杭电后边的测试数据
input:
5 5
Y..#@
...M#
.....
.....
@....

output:
110

/*
没想到有一个点到达不了的时候,,初始化为0 一直wa,,,还好看了杭电后边的测试数据。。。。。。改了,,过了。。。。加油!!!
Time:2014-12-29 18:22
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int MAX=205;
int move[4][2]={0,1,0,-1,1,0,-1,0};
struct Node{
    int x,y;
    int steps;
    friend bool operator<(Node a,Node b){
        return a.steps>b.steps;
    }
}s1,s2;
int n,m;
char g[MAX][MAX];
int maze1[MAX][MAX],maze2[MAX][MAX];
bool vis[MAX][MAX];
void BFS(Node s,int (*maze)[MAX]){
    queue<Node>q;
    Node cur,temp;
    q.push(s);vis[s.x][s.y]=true;
    while(!q.empty()){
        cur=q.front();q.pop();
         for(int i=0;i<4;i++){
                temp=cur;
            temp.x+=move[i][0];
            temp.y+=move[i][1];
            if(temp.x>=0&&temp.x<n && temp.y>=0&&temp.y<m
               && g[temp.x][temp.y]!='#'&&!vis[temp.x][temp.y]){
                vis[temp.x][temp.y]=true;
                temp.steps=cur.steps+1;
                maze[temp.x][temp.y]=temp.steps;
               q.push(temp);
            }
        }
    }
    return;
}

int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        //memset(maze1,0,sizeof(maze1));
        //memset(maze2,0,sizeof(maze2));
        memset(g,0,sizeof(g));
        for(int i=0;i<n;i++){
            scanf("%s",g[i]);
            for(int j=0;j<m;j++){
                if(g[i][j]=='Y'){
                    s1.x=i;s1.y=j;
                    s1.steps=0;
                }else if(g[i][j]=='M'){
                    s2.x=i;s2.y=j;
                    s2.steps=0;
                }
                maze1[i][j]=INF;
                maze2[i][j]=INF;
            }
        }
        memset(vis,0,sizeof(vis));
        BFS(s1,maze1);
        memset(vis,0,sizeof(vis));
        BFS(s2,maze2);
        /*
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++)
            printf(" %d",maze1[i][j]);
        puts("");
        }puts("");
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++)
            printf(" %d",maze2[i][j]);
        puts("");
        }*/
        int ans=MAX*MAX;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(g[i][j]=='@'){
                   ans=min(ans,(maze1[i][j]+maze2[i][j]));
                }
            }
        }
        printf("%d\n",ans*11);
    }
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值