poj3090 Visible Lattice Points(莫比乌斯反演)

Visible Lattice Points
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5724 Accepted: 3374

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

Greater New York 2006
/*
2014年最后一道题,莫比乌斯反演直接求的,发现结果总是少2,然后就加了2,就过了,为什么呢?后来想想,应该是缺了(1,0)和(0,1)这两个点了吧,因为莫比乌斯反演是从1开始的,,,加油!!!
Time:2014-12-31 21:52
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAX=1010;
int prime[MAX+10],mu[MAX+10];
bool vis[MAX+10];
void Mobius(){
    memset(prime,0,sizeof(prime));
    memset(vis,0,sizeof(vis));
    mu[1]=1;vis[1]=true;int cnt=0;
    for(int i=2;i<=MAX;i++){
        if(!vis[i]){
            prime[cnt++]=i;
            mu[i]=-1;
        }
        for(int j=0;j<cnt;j++){
            if(i*prime[j]>MAX)break;
            vis[i*prime[j]]=true;
            if(i%prime[j]==0){
                mu[i*prime[j]]=0;
                break;
            }
            mu[i*prime[j]]=-mu[i];
        }
    }
}
int main(){
    int nCase,T,n;
    Mobius();
    nCase=1;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        LL ans=0;
        for(int i=1;i<=n;i++){
            ans+=(LL)(n/i)*(n/i)*mu[i];
        }
        printf("%d %d %lld\n",nCase++,n,ans+2);
    }
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值