zoj1610 Count the Colors(线段树)

Count the Colors


Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1



Author: Standlove
Source: ZOJ Monthly, May 2003
/*
区间更新,左闭右开区间
Time:2015-1-19 15:06
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=8000+10;
#define lson l,mid,rt<<1
#define rson mid,r,rt<<1|1
const int N=8001;
struct Tree{
    int flag;
}tree[MAX<<2];
int pre,color[MAX+10];//表示颜色i的数量
void Build(int l,int r,int rt){
    tree[rt].flag=-1;
    if(l+1==r)return;//左闭右开区间
    int mid=(l+r)>>1;
    Build(lson);
    Build(rson);
}
void Insert(int L,int R,int c,int l,int r,int rt){
    if(l==r)return;//不操作
    if(tree[rt].flag==c) return;
    if(L<=l&&R>=r){
        tree[rt].flag=c;
        return ;
    }
    if(tree[rt].flag>=0){
        tree[rt<<1].flag=tree[rt].flag;
        tree[rt<<1|1].flag=tree[rt].flag;
        tree[rt].flag=-2;//有多种颜色
    }
    int mid=(l+r)>>1;
    if(R<=mid)  Insert(L,R,c,lson);
    else if(L>=mid) Insert(L,R,c,rson);
    else{
        Insert(L,mid,c,lson);
        Insert(mid,R,c,rson);
    }
    tree[rt].flag=-2;//如果有1种颜色,前边已经返回
}
void Query(int l,int r,int rt){//因为递归访问的时候也是从小到大的
    if(tree[rt].flag==-1){
        pre=-1;//没有覆盖
        return;
    }
    if(tree[rt].flag!=-2){//只有一种颜色
        if(tree[rt].flag!=pre){
            color[tree[rt].flag]++;//该颜色数量+1
            pre=tree[rt].flag;//更新pre
        }
        return;//计数后,返回
    }
    if(l+1==r)return;//左闭右开,已经更新到底了,返回
    int mid=(l+r)>>1;
    Query(lson);
    Query(rson);
}
int main(){
    int n,a,b,c;
    int maxC;
    while(scanf("%d",&n)!=EOF){
        memset(tree,0,sizeof(tree));//无语,放到了建树后边,刚建好又直接清空掉
        Build(0,N,1);
        memset(color,0,sizeof(color));
        maxC=0;
        while(n--){
            scanf("%d%d%d",&a,&b,&c);
            Insert(a,b,c,0,N,1);
            maxC=maxC>c?maxC:c;
        }
        Query(0,N,1);
        for(int i=0;i<=maxC;i++){
            if(color[i]){
                printf("%d %d\n",i,color[i]);
            }
        }puts("");
    }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值