hdu2444 The Accomodation of Students(判联通+二分匹配)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2837    Accepted Submission(s): 1322


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3
 

Source
二分图匹配数的一半简单证明链接
/*
用dfs标号哪儿错了?。。。费解。。。 二分图输入没有分类,加上双向边直接找到总数再除以二
Time:2015-2-3 16:55
*/
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int MAX=205;
vector<vector<int> >G(MAX);
int n,m;
bool vis[MAX];
int linker[MAX];
bool DFS2(int u){
    for(int i=0;i<G[u].size();i++){
        int v=G[u][i];
        if(!vis[v]){
            vis[v]=true;
            if(linker[v]==-1||DFS2(linker[v])){
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary(){
    int ans=0;
    memset(linker,-1,sizeof(linker));

    for(int i=1;i<=n;i++){
        memset(vis,0,sizeof(vis));
        if(DFS2(i)) ans++;
    }
    return ans>>1;
}

/*
bool DFS1(int u,int c){
    for(int i=0;i<G[u].size();i++){
        int v=G[u][i];
        if(color[v]==c){
            return false;
        }else if(!color[v]){
            color[v]=-c;
            DFS1(v,color[v]);
        }
    }
    return true;
}
*/
int color[MAX];
bool BFS(int S){
    queue<int>q;
    while(!q.empty())q.pop();
    q.push(S);color[S]=1;
    while(!q.empty()){
        int u=q.front();q.pop();

        for(int i=0;i<G[u].size();i++){
            int v=G[u][i];
            if(!color[v]){
                color[v]=-color[u];
                q.push(v);
            }else if(color[v]==color[u])
                return false;
        }
    }
    return true;
}
bool Judge(){
    memset(color,0,sizeof(color));
    color[1]=1;//白色为1,黑色为-1
    if(BFS(1))return true;
    else return false;
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<=n;i++)G[i].clear();
        int u,v;
        while(m--){
            scanf("%d%d",&u,&v);
            G[u].push_back(v);
            G[v].push_back(u);
        }
        if(!Judge()) printf("No\n");
        else printf("%d\n",hungary());
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值