POJ 1969---Count on Canton【数学问题】

Count on Canton
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9138 Accepted: 5354

Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below. 
1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4

3/1 3/2 3/3

4/1 4/2

5/1


In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input

The input list contains a single number per line and will be terminated by endof-file.

Output

You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.

Sample Input

   
   
3
14
7

Sample Output

   
   
TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


解析:本题可以斜着看成一个金字塔,然后你就会发现分子分母之和恒等于本行行数n-1.
     而且分子是从左到右递减的,而分母是递增的。
     所以。。。。你懂得~~~
插入代码:
#include<stdio.h>
int a[4001];
int main()
{
    int m,i;
    a[1]=1;
    for(i=2;a[i]<=10000000;i++)
    {
        a[i]=a[i-1]+i;
    }
    while(~scanf("%d",&m))
    {
        for(i=1;i<=4000;i++)
        {
            if(a[i]>=m)
            break;
        }
        printf("TERM %d IS ",m);
        if(i%2==1)
        printf("%d/%d\n",1+a[i]-m,i-a[i]+m);
        else printf("%d/%d\n",i-a[i]+m,1+a[i]-m);

    }
    return 0;
}

 
  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值