唯一分解定理 (Choose and Divide Uva10375)

The binomial coefficient C(m; n) is defined as
C(m; n) = m!
(m - n)! n!
Given four natural numbers p, q, r, and s, compute the the result of dividing C(p; q) by C(r; s).
Input
Input consists of a sequence of lines. Each line contains four non-negative integer numbers giving values
for p, q, r, and s, respectively, separated by a single space. All the numbers will be smaller than 10,000
with p q and r s.
Output
For each line of input, print a single line containing a real number with 5 digits of precision in the fraction, giving the number as described above. You may assume the result is not greater than 100,000,000.
Sample Input
10 5 14 9
93 45 84 59
145 95 143 92
995 487 996 488
2000 1000 1999 999
9998 4999 9996 4998
Sample Output
0.12587
505606.46055
1.28223
0.48996
2.00000
3.99960

简单翻译一下,告诉你p,q,r,s求C(p,q)/C(r,s)

简单的暴力是不可能过得,所以我们要用数学的方法,我们运用唯一分解法,将质因数分解之后存在数组中,这样乘除就是这个因数的个数的加减,最后将所有因数乘起来就可以了~

#include<bits/stdc++.h>
using namespace std;
vector<int> prime;
int book[20000],e[20000];

void add_integer(int n,int d)
{
	for(int i=0;i<prime.size();i++)
	{
		while(n%prime[i]==0)
		{
			e[i]+=d;
			n/=prime[i];
		}
		if(n==1) break;
	}
}

void add(int n,int d)
{
	for(int i=1;i<=n;i++)
		add_integer(i,d);
}

void init()
{
	book[1]=1;
	for(int i=2;i<=101;i++)
		if(!book[i])
		for(int j=i*i;j<=10000;j+=i)
			book[j]=1;
	for(int i=1;i<=10000;i++)
		if(!book[i])
			prime.push_back(i);
}

double Pow(int a,int b)
{
	int ok=0;
	if(b==0) return 1;
	if(b<0) ok=1,b=-b;
	double ans=1;
	for(int i=1;i<=b;i++)
		ans*=double(a);
	if(ok) return double(1/ans);
	return ans;
}

int main()
{
	init();
	int p,q,r,s;
	while(cin>>p>>q>>r>>s)
	{
		memset(e,0,sizeof(e));
		add(p,1);
		add(q,-1);
		add(p-q,-1);
		add(r,-1);
		add(s,1);//作为除数的话和前面的正好相反 
		add(r-s,1);
		double ans=1;
		for(int i=0;i<prime.size();i++)
			ans*=Pow(prime[i],e[i]);
		printf("%.5lf\n",ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值