次小生成树(LA5713)

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in
China | they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom
Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor
of a unified China in 221 BC. That was Qin dynasty | the first imperial dynasty of China(not to be
confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi
Huang" because "Shi Huang" means "the first emperor " in Chinese.
Qin Shi Huang undertook gigantic projects, including the
first version of the Great Wall of China, the now famous citysized mausoleum guarded by a life-sized Terracotta Army, and
a massive national road system. There is a story about the
road system:
There were n cities in China and Qin Shi Huang wanted
them all be connected by n - 1 roads, in order that he could
go to every city from the capital city Xianyang. Although
Qin Shi Huang was a tyrant, he wanted the total length of
all roads to be minimum,so that the road system may not
cost too many people’s life. A daoshi (some kind of monk)
named Xu Fu told Qin Shi Huang that he could build a road
by magic and that magic road would cost no money and no
labor. But Xu Fu could only build ONE magic road for Qin
Shi Huang. So Qin Shi Huang had to decide where to build
the magic road. Qin Shi Huang wanted the total length of all
none magic roads to be as small as possible, but Xu Fu wanted
the magic road to benefit as many people as possible | So
Qin Shi Huang decided that the value of A=B (the ratio of A
to B) must be the maximum, which A is the total population
of the two cites connected by the magic road, and B is the
total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two
points.
Input
The first line contains an integer t meaning that there are t test cases (t 10).
For each test case:
The first line is an integer n meaning that there are n cities (2 < n 1000).
Then n lines follow. Each line contains three integers X, Y and P (0 X; Y 1000; 0 < P <
100000). (X; Y ) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
Output
For each test case, print a line indicating the above mentioned maximum ratio A=B. The result should
be rounded to 2 digits after decimal point.
Sample Input
2 4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
Sample Output
65.00
70.00

这题应该算是次小生成树的裸题把,跑一边最小生成树,然后枚举maxcost,然后用两个点的人口,减去这个边的权值,做商就可以了。

调试了好久,也拿别人的代码比对了好久,发现原来是没有初始化。。

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<set>
#include<cmath>
#define maxn 2000
#define inf 2183984200
using namespace std;
struct Edge{int from,to;double w;}p[maxn*maxn];
int head[maxn],book[maxn],pre[maxn];

int find(int x){return x==pre[x]?x:pre[x]=find(pre[x]);}
bool cmp(Edge a,Edge b){return a.w<b.w;}

int n,m,num;
int x[maxn],y[maxn],cost[maxn];
double d[maxn][maxn];
double ans1=0;
double dis(int i,int j){return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));}
vector<int> G[maxn];
vector<double> c[maxn];

void Kruscal()
{
	cin>>n;
	for(int i=1;i<=n;i++)
		cin>>x[i]>>y[i]>>cost[i];
	for(int i=1;i<=n;i++)
		for(int j=i+1;j<=n;j++) 
			p[++m]=Edge{i,j,dis(i,j)};
	for(int i=1;i<=n;i++)
		pre[i]=i;
	sort(p+1,p+m+1,cmp);
	for(int i=1;i<=m;i++)
	{
		int fx=find(p[i].from),fy=find(p[i].to);
		if(pre[fx]!=fy)
		{
			ans1+=p[i].w;
			pre[fx]=fy;
			num++;
			G[p[i].from].push_back(p[i].to);c[p[i].from].push_back(p[i].w);
			G[p[i].to].push_back(p[i].from);c[p[i].to].push_back(p[i].w);
		}
		if(n-1==num)break ;
	}
}

void dfs(int now,int x,int fa,double wc)
{
	d[now][x]=wc;
	for(int i=0;i<G[x].size();i++)
		if(G[x][i]!=fa)
			dfs(now,G[x][i],x,max(c[x][i],wc));
}

void init()
{
	memset(G,0,sizeof(G));
	memset(c,0,sizeof(c));
	ans1=0;m=0;num=0;
	memset(pre,0,sizeof(pre));
	memset(p,0,sizeof(p));
	memset(x,0,sizeof(x));
	memset(y,0,sizeof(y));
	memset(cost,0,sizeof(cost));
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		init();
		Kruscal();
		for(int i=1;i<=n;i++)
			dfs(i,i,-1,0);
		double ans=-1;
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				ans=max(ans,(cost[i]+cost[j])/(ans1-d[i][j]));
		printf("%.2lf\n",ans);		
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值