Time Limit: 1000MS | Memory Limit: 32768KB | 64bit IO Format: %I64d & %I64u |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
dfs @为起点,可以上下左右四个方向扩展,
只能走点,问可以到达多少个位置。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <math.h>
#include <queue>
using namespace std;
#define maxn 50
char s[maxn][maxn];
int n,m;
int ans;
int sx,sy;
int dx[]={1,-1,0,0};
int dy[]={0,0,-1,1};
bool check(int x,int y)
{
if(x<n && x>=0 &y>=0 && y<m)
return 1;
return 0;
}
void dfs(int x,int y)
{
ans++;
s[x][y]='#';
for(int i=0;i<4;i++)
{
if(check(x+dx[i],y+dy[i]) && s[x+dx[i]][y+dy[i]]=='.')
dfs(x+dx[i],y+dy[i]);
}
}
int main()
{
while(~scanf("%d%d",&m,&n) && (n+m))
{
ans=0;
for(int i=0;i<n;i++)
scanf("%s",s[i]);
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(s[i][j]=='@')
sx=i,sy=j;
dfs(sx,sy);
cout<<ans<<endl;
}
return 0;
}