ZOJ 3432 Find the Lost Sock

Find the Lost Sock

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

Alice wants to know which sock she has lost. Maybe you can help her.

Input

There are multiple cases. The first line containing an integer n (1 <= n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line is a string with 7 charaters indicating the name of the socks that Alice took back.

Output

The name of the lost sock.

Sample Input
2
aabcdef
bzyxwvu
bzyxwvu
4
aqwerty
eas fgh
aqwerty
easdfgh
easdfgh
aqwerty
aqwerty
2
0x0abcd
0ABCDEF
0x0abcd
Sample Output
aabcdef
eas fgh
0ABCDEF
 
题意:每双袜子有7个相同字符,找出丢失一只的袜子。
思路:先用暴力一个个比较再标记,n有1000000 超时,经指点用了位异或,发现位异或新用法0.0,或许是我从来没想过可以这样用= =,果然是——还差得远呢!。。

 

 
 
Accepted3432C++730ms272kb

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

char a[10],ans[10];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        memset(ans,0,sizeof(ans));
        for(int i = 0; i < 2*n-1; i++)
        {
            for(int j = 0; j < 7; j++)
            {
                scanf("%c",&a[j]);
                ans[j] ^= a[j];
            }
            getchar();

        }
        ans[7] = '\0';
        printf("%s\n",ans);
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值