hdu 1007 Quoit Design(二维 最近点对)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1007


Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31319    Accepted Submission(s): 8240


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 

三种情况:

1),点在(left,mid)中;

2),点在(mid+1,right)中;

3),跨越了mid,这时就要考虑合并区间,并优化

将距离mid节点小于d的点全部放在node a 里面,然后对a进行y轴排序,如果两点的y轴距离大于d,则break;

不然,则取最小值即可,还要注意的就是递归时的终止条件,相差1则取距离即可;

注意:查找与mid点距离小于d的点时,我开始用的是a数组保存节点位置,然后在对节点进行y排序,可是TLE了,然后我把a数组直接换成了节点,直接对a进行y轴排序,在进行查找就过了 = =,到底是什么原因呢?,难道是排序的时候出问题了?。。。。。。。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;
int n;
struct Node
{
    double x,y;
}node[100005];

Node a[100005];

double min(double x,double y)
{
    return x<y? x:y;
}

int cmpx(Node a,Node b)
{
    return a.x < b.x;
}
int cmpy(Node a,Node b)
{
    return a.y < b.y;
}
double dis(Node a, Node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

double dfs(int left,int right)
{
    //printf("%d %d\n",left,right);
    if(left == right-1)
        return dis(node[left],node[right]);

    if(left == right-2)
        return min(dis(node[left],node[right]),min(dis(node[left],node[left+1]),dis(node[left+1],node[right])));

    int mid = (left+right)>>1;
    double d = min(dfs(left,mid),dfs(mid+1,right));

    int top = 0;
    //合并区间
    for(int i=left;i<=right;i++)
    {
        if((node[i].x>=node[mid].x-d) && (node[i].x <= node[mid].x+d))//记录在区间[-d,+d]之间的点
            a[top++]=node[i];
    }

    sort(a,a+top,cmpy);

    for(int i=0;i<top;i++)
    {
        for(int j = i+1;j<top;j++)
        {
            if(a[j].y - a[i].y  >= d) //当y轴距离超过d也可以跳过
                break;
            d= min(d,dis(a[i],a[j]));
        }
    }
    return d;

}

int main()
{
    while(scanf("%d",&n) && n)
    {
        int i;
        for(i=0;i<n;i++)
            scanf("%lf %lf",&node[i].x,&node[i].y);

        sort(node,node+n,cmpx);

        double result = dfs(0,n-1);
        printf("%.2f\n",result/2);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值