POJ 3259 Wormholes(Bellman-Ford)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27859 Accepted: 10026

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

 

题意:有M个可以连接两个点的路径(双向性),有W个虫洞(权值一定为负,且单向,且时光倒流,扯~)。然后来判断能否遇见曾经的自己。。。(说白了就是Bellman算法求有无负圈)

 

代码:

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

#define N 505
#define inf 1e9

int d[N];
int n,m;

struct edge
{
    int x;
    int y;
    int w;
}ed[5300];


int bellman(int l)
{
    int i,j;
    int ok;
    for(i = 1; i <= n; i++)
        d[i] = inf;
    d[1] = 0;
    for(i = 1; i <= n-1; i++)
    {
        ok = 0;
        for(j = 1; j <= l; j++)
        {
            if(d[ed[j].x] > d[ed[j].y] + ed[j].w)
            {
                d[ed[j].x] = d[ed[j].y] + ed[j].w;
                ok = 1;
            }
        }
        if(!ok)
            break;
    }
    for(j = 1; j <= l; j++)
    {
        if(d[ed[j].x] > d[ed[j].y] + ed[j].w)
            return 0;
    }
    return 1;
}

int main()
{
    int i,j,t;
    int a,b,c,w;
//    freopen("ojin.txt","r",stdin);
//     freopen("ojout.txt","w",stdout);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d", &n, &m, &w);
        memset(ed, 0, sizeof(ed));
        for(i = 0,j = 1;j <= m; j++)
        {
            scanf("%d%d%d", &a, &b, &c);
            i++;
            ed[i].x = a;
            ed[i].y = b;
            ed[i].w = c;
            i++;
            ed[i].x = b;
            ed[i].y = a;
            ed[i].w = c;
        }
        for(j = 1;j <= w; j++)
        {
            scanf("%d%d%d",&a,&b,&c);
            i++;
            ed[i].x = a ;
            ed[i].y = b;
            ed[i].w = -c;
        }
        if(bellman(i))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值