A - Wormholes
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2…M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2…M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1…F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意描述:
John的农场里N块地,M条路连接两块地,W个虫洞;路是双向的,虫洞是一条单向路,会在你离开之前把你传送到目的地,就是当你过去的时候时间会倒退Ts。要求判断会不会在从某块地出发后又回来,看到了离开之前的自己。
解题思路:
其实就是想让我们判断回路中是否存在一个负环,用bellman-ford算法来求负环,松弛结束后判断是否存在最短路,不存在则有负环。
bellman-ford:
#include <stdio.h>
#define inf 0x3f3f3f3f
struct Edge
{
int u, v, w;
}e[11000];//邻接表
int bellman(int x);
void relax(int u,int v,int w);
void add(int u, int v, int w);
int dis[11000];
int n, m, W, k;
int main()
{
int i,T,u,v,w;
scanf("%d",&T);
while(T--)
{
k=1;
scanf("%d%d%d",&n,&m,&W);
for(i=1;i<=m;i++)//路(双向的)
{
scanf("%d%d%d",&u,&v,&w);
add(u, v, w);
add(v, u, w);
}
for(i=1;i<=W;i++)//虫洞(单向的)
{
scanf("%d%d%d",&u,&v,&w);
add(u, v, -w);
}
if(bellman(n))
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
return 0;
}
int bellman(int x)
{
int i,j;
for(i=1;i<=n;i++)
{
dis[i]=inf;
}
//dis[x]=0;
for(i=0;i<n;i ++)//松弛n-1次
{
for(j=1;j<=k;j++)//遍历每一条边
{
relax(e[j].u,e[j].v,e[j].w);
}
}
for(i=1;i<=k;i++)//负环
{
if(dis[e[i].v]>dis[e[i].u]+e[i].w)
{
return 1;
}
}
return 0;
}
void relax(int u,int v,int w)
{
if(dis[v] > dis[u] + w)
dis[v] = dis[u] + w;
}
void add(int u, int v, int w)
{
e[k].u = u, e[k].v = v, e[k++].w = w;
}