BUAAoj_A+B

大数相加

Problem Description

升级版的A+B,要考虑大数问题

Input

第一个数为数据组数n,接下来n行,每行2个整数a,b

Output

对于每组数据,输出一行,a+b的值

Sample Input

1
111111111111111111111111111111111 222222222222222222222222222222222

Sample Output

333333333333333333333333333333333
代码:
#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		char a[50],b[50];
		int c[50]={0},d[50]={0},i,x1,x2,y,m;
        scanf("%s",&a);
		scanf("%s",&b);
		x1=strlen(a);
		x2=strlen(b);
		if(x2>x1)
			m=x2;
		else
			m=x1;
		    y=m;
			for(i=0;i<x1;m--,i++)
				c[m]=a[x1-i-1]-'0';
			for(m=y,i=0;i<x2;m--,i++)
				d[m]=b[x2-i-1]-'0';
			
			for(i=y;i>=0;i--){
				c[i]+=d[i];
			if(c[i]>=10){
				c[i]-=10;
			    c[i-1]++;
			}
			
			}
			if(c[0]!=0){
				for(i=0;i<=y;i++)
					printf("%d",c[i]);
			}
			else{
					for(i=1;i<=y;i++)
						printf("%d",c[i]);
			}
					printf("\n");
			
	}
 return 0;
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值