HDU-1200To and Fro

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab

代码:

 #include <stdio.h>  
 #include <string.h>  
      
 int main()  
 {  
        char s[30][200],str[300];  
        int n,i,j,k,len;  
        while(scanf("%d",&n),n)  
        {  
            scanf("%s",str);  
            len = strlen(str);  
            memset(s,'\0',sizeof(s));//字符串是以'\0'为结束符的  
            k = 0;  
            for(i = 0;i<len/n && k<len;i++)  
            {  
                for(j = 0;j<n;j++)  
                {  
                    if(i%2)  
                    s[i][n-j-1] = str[k++];//偶数行逆序输出  
                    else  
                    s[i][j] = str[k++]; //奇数行原序输出
                }  
            }  
            for(i = 0;i<n;i++)  
            {  
                for(j = 0;j<len/n;j++)  
                {  
                    printf("%c",s[j][i]);  
                }  
            }  
            printf("\n");  
        }  
        return 0;  
    } 
解题思路:

题目的意思是,已知字符串满足规则:按"列"从上到下,从左到右排列字母 ,按"行"(奇数行) 从左到右 和( 偶数行)从右到左 交替读取,从而形成了字符矩形由此根据这个产生的字符序列还原出原来的字符串顺序。

行列排列问题,用二维数组处理,直接模拟。

还有另一种思路:由于是先从左到右再从右到左,然后再从左到右再从右到左,所以每2*n是一个循环,然后找位置,对每个2*n内的第i和第2*n-i-1输出即可。

#include <iostream>
#include<stdio.h>
#include <string>
using namespace std;

int main()
{
    int n,a,b;// a 表示现在的位置,b 表示找到下一个字母所要跳过的步数
    char str[400];
    while(cin>>n && n)
    {
        scanf("%s",str);
        int L = strlen(str);
        a = 0;
        for(int i=0;i<n;++i)
        {
            a = i; 
            b = 2*n-1-2*i;
            while(a < L)
            {
                cout<<str[a];
                a += b;
                b = 2*n-b;//每 2*n 是一个循环
            }
        }
        cout<<endl;
		getchar();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值