poj--1961--KMP

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 14046 Accepted: 6647

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa

12

aabaabaabaab 0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

 

/*一道比较水的字符处理的题目,题意大概是给你一个长度为N的字符串,全是由小写的英文字母组成,需要你找出该字符串的所有前缀中所有的满足

形势的前缀,输出A, K.. */

/*因为正在复习KMP,所以找了这个题目。刚开始看的时候觉的和KMP没有什么关系。。。。。。 但是好好琢磨之后才发现这是用了KMP中next数组的性质*/

<span style="font-size:14px;">#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;

int Next[1000010];
int m;
char x[1000010];
void kmp_pre()

{
	int i,j;
	j=Next[0]=-1;
	i=0;
	while(i<m){
		while (-1!=j && x[i]!=x[j])j=Next[j];
		Next[++i]=++j;
	}
}


int main()
{
	//freopen("test.in","r",stdin);
	int j=1;
	while(scanf("%d",&m))
	{
		if(m==0)
		break;
		scanf("%s",x);
		kmp_pre();
		printf("Test case #%d\n",j++ );
		for(int i=1;i<=m;i++)
		{
			int k=i-Next[i];
			if(i/k>1&&i%k==0)
				printf("%d %d\n",i,i/k);
		}
		printf("\n");
	}
	return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值