HDU-1506


Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13452    Accepted Submission(s): 3804


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000
 

Source
 


我在想这题为什么和dp有关啊?      暂时还不知道  

我认为就是一道思维题吧

对于每个小长方形的高度 我们需要求出以它为高的左右边界 左边的比它本身高的话,就一直递归找下去。右边也是这样。



#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;
#define ll long long
#define Maxn 100010


int main()
{
	//freopen("in.in","r",stdin);
	int n;
	while(scanf("%d",&n)!=EOF&&n)
	{
        int l[Maxn],r[Maxn];
        ll a[Maxn];
        ll maxn,area;
		for(int i=1;i<=n;i++)
		{
			cin>>a[i];
			r[i]=l[i]=i;
		}
		a[0]=a[n+1]=-1;
		for(int i=1;i<=n;i++)
		{
			while(a[l[i]-1]>=a[i])
			{
				l[i]=l[l[i]-1];
			}
		}

		for(int i=n;i>=1;i--)
		{
			while(a[r[i]+1]>=a[i])
			{
				r[i]=r[r[i]+1];
			}
		}

		maxn=0;
		for(int i=1;i<=n;i++)
		{
			area=(r[i]-l[i]+1)*a[i];
			maxn= area>maxn?area:maxn;
		}
		printf("%lld\n",maxn);
	}
	return 0;
}



### HDU OJ 2089 Problem Solution and Description The problem titled "不高兴的津津" (Unhappy Jinjin) involves simulating a scenario where one needs to calculate the number of days an individual named Jinjin feels unhappy based on certain conditions related to her daily activities. #### Problem Statement Given a series of integers representing different aspects of Jinjin's day, such as homework completion status, weather condition, etc., determine how many days she was not happy during a given period. Each integer corresponds to whether specific events occurred which could affect her mood positively or negatively[^1]. #### Input Format Input consists of multiple sets; each set starts with two positive integers n and m separated by spaces, indicating the total number of days considered and types of influencing factors respectively. Following lines contain details about these influences over those days until all cases are processed when both numbers become zero simultaneously. #### Output Requirement For every dataset provided, output should be formatted according to sample outputs shown below: ```plaintext Case k: The maximum times of appearance is x, the color is c. ``` Where `k` represents case index starting from 1, while `x` stands for frequency count and `c` denotes associated attribute like colors mentioned earlier but adapted accordingly here depending upon context i.e., reasons causing unhappiness instead[^2]. #### Sample Code Implementation Below demonstrates a simple approach using Python language to solve this particular challenge efficiently without unnecessary complexity: ```python def main(): import sys input = sys.stdin.read().strip() datasets = input.split('\n\n') results = [] for idx, ds in enumerate(datasets[:-1], start=1): data = list(map(int, ds.strip().split())) n, m = data[:2] if n == 0 and m == 0: break counts = {} for _ in range(m): factor_counts = dict(zip(data[2::2], data[3::2])) for key, value in factor_counts.items(): try: counts[key] += value except KeyError: counts[key] = value max_key = max(counts, key=lambda k:counts[k]) result_line = f'Case {idx}: The maximum times of appearance is {counts[max_key]}, the reason is {max_key}.' results.append(result_line) print("\n".join(results)) if __name__ == '__main__': main() ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值