Left Mouse Button

Description

Mine sweeper is a very popular small game in Windows operating system. The object of the game is to find mines, and mark them out. You mark them by clicking your right mouse button. Then you will place a little flag where you think the mine is. You click your left mouse button to claim a square as not being a mine. If this square is really a mine, it explodes, and you lose. Otherwise, there are two cases. In the first case, a little colored numbers, ranging from 1 to 8, will display on the corresponding square. The number tells you how many mines are adjacent to the square. For example, if you left-clicked a square, and a little 8 appeared, then you would know that this square is surrounded by 8 mines, all 8 of its adjacent squares are mines. In the second case, when you left-click a square whose all adjacent squares are not mines, then all its adjacent squares (8 of its adjacent squares) are mine-free. If some of these adjacent squares also come to the second case, then such deduce can go on. In fact, the computer will help you to finish such deduce process and left-click all mine-free squares in the process. The object of the game is to uncover all of the non-mine squares, without exploding any actual mines. Tom is very interesting in this game. Unfortunately his right mouse button is broken, so he could only use his left mouse button. In order to avoid damage his mouse, he would like to use the minimum number of left clicks to finish mine sweeper. Given the current situation of the mine sweeper, your task is to calculate the minimum number of left clicks.

Input

The first line of the input contains an integer T (T <= 12), indicating the number of cases. Each case begins with a line containing an integer n (5 <= n <= 9), the size of the mine sweeper is n×n. Each of the following n lines contains n characters M ij(1 <= i,j <= n), M ij denotes the status of the square in row i and column j, where ‘@’ denotes mine, ‘0-8’ denotes the number of mines adjacent to the square, specially ‘0’ denotes there are no mines adjacent to the square. We guarantee that the situation of the mine sweeper is valid.

Output

For each test case, print a line containing the test case number (beginning with 1) and the minimum left mouse button clicks to finish the game.

Sample Input

1
9
001@11@10
001111110
001111110
001@22@10
0012@2110
221222011
@@11@112@
2211111@2
000000111

Sample Output

Case 1: 24

简单搜索,比赛时没看懂题。。。

解题思路:每次左键按在0位置的可以最大范围的扩大安全区域,
把成块的零区域连起来,外面有一层非零的格子;
再加上未不和零直接相邻的数字格子,就得到了答案。
如例子:零区域有4处,然后,加上剩下的20个格子就是24;

dfs:

#include<stdio.h>
#include<string.h> 
#define N 20  
char str[N][N];  
int mark[N][N],n;  
int dir[8][2]={0,1,0,-1,1,0,-1,0,-1,-1,-1,1,1,-1,1,1};//8个方向  
void dfs(int x,int y)  
{  
    int i,di,dj;  
    if(str[x][y]!='0')            //不是零就返回  
        return ;  
    for(i=0;i<8;i++)  
    {  
        di=dir[i][0]+x;  
        dj=dir[i][1]+y;  
        if(di>=0&&di<n&&dj>=0&&dj<n&&!mark[di][dj])   //搜过的不能再搜,否则会死循环  
        {  
            mark[di][dj]=1;  
            dfs(di,dj);  
        }  
    }  
}  
int main()  
{  
    int i,j,T,ans,cnt=1;  
    scanf("%d",&T);  
    while(T--)  
    {  
        scanf("%d",&n);  
        for(i=0;i<n;i++)  
            scanf("%s",str[i]);  
        memset(mark,0,sizeof(mark));  
        ans=0;  
        for(i=0;i<n;i++)  
            for(j=0;j<n;j++)  
                if(mark[i][j]==0&&str[i][j]=='0')//搜索共有几处0区域并标记  
                {  
                    mark[i][j]=1;  
                    dfs(i,j);  
                    ans++;  
                }  
        for(i=0;i<n;i++)  
            for(j=0;j<n;j++)         //加上剩余的非零格子  
            {  
                if(!mark[i][j]&&str[i][j]!='@')  
                    ans++;  
            }  
        printf("Case %d: %d\n",cnt++,ans);  
    }  
    return 0;  
}  

bfs:

#include<stdio.h>
#include<string.h>

char map[9][9];
int frist,last,n;
int dir[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,-1,-1,1,1,-1};

struct node{
    int x,y;
};
struct node d[50];

void bfs(void)
{
    while(frist<last)
    {
        if(map[d[frist].x][d[frist].y]=='0') for(int i=0;i<8;++i)
        {
            d[last].x=d[frist].x+dir[i][0];
            d[last].y=d[frist].y+dir[i][1];
            if(d[last].x>=0&&d[last].x<n&&d[last].y>=0&&d[last].y<n&&map[d[last].x][d[last].y]!='@') last++;
        }
        map[d[frist].x][d[frist].y]='@';
        frist++;
    }
}
int main(void)
{
    int t,x,y,sum,m=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;++i)
            scanf("%s",map[i]);
        sum=0;
        for(int i=0;i<n;++i)
            for(int j=0;j<n;++j)
                if(map[i][j]=='0')
                {
                    sum++;
                    frist=last=0;
                    d[last].x=i;
                    d[last].y=j;
                    last++;
                    bfs();
                }
        for(int i=0;i<n;++i)
            for(int j=0;j<n;++j)
                if(map[i][j]!='@') sum++;
        printf("Case %d: %d\n",m++,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值