HDU1598find the most comfortable road(并查集)

31 篇文章 0 订阅
14 篇文章 0 订阅
Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。
 

Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。
 

Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。
 

Sample Input
  
  
4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2
 

Sample Output
  
  
1 0
思路: 将速度从低到高排序,然后依次插入边 记住更新最小值。
#include <iostream>
#include <cstdio>
#include <algorithm>
#define N 204
using namespace std;
int par[N];
struct way
{
    int s,e,v;
}r[1001];
void Init()
{
    for(int i=0;i<204;i++)
        par[i]=i;
}
int findroot(int x)
{
    if(par[x]!=x)
        return par[x]=findroot(par[x]);
    return par[x];
}
void unite(int x,int y)
{
   x=findroot(x);
   y=findroot(y);
   if(x==y)
    return;
   else
    par[y]=x;
}
bool cmp(const struct way &a,const struct way &b)
{
    return a.v<b.v;
}
int main()
{
    int n,m,p;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<m;i++)
            cin>>r[i].s>>r[i].e>>r[i].v;
        sort(r,r+m,cmp);
        int a,b;
        cin>>p;
        while(p--)
        {
            cin>>a>>b;
            int ans=0;
            int mmin=100000000;
            ans=mmin;
            for(int i=0;i<m;i++)
            {
                Init();
                for(int j=i;j>=0;j--)
                {
                    unite(r[j].s,r[j].e);
                    if(findroot(a)==findroot(b))
                    {
                        ans=r[i].v-r[j].v;
                        break;
                    }
                }
                if(ans<mmin)
                    mmin=ans;
            }
            if(mmin==100000000)
                cout<<-1<<endl;
            else
                cout<<mmin<<endl;
        }
    }
    return 0;
}



 
  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值