杭电ACM A + B Problem II


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2300 Accepted Submission(s): 886
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output

            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
Author
Ignatius.L
问题好上:

我花了差不多两小时才做出了这道题啊,写一下:
/*
A + B Problem II
*/

#include<iostream>
#include<string>
using namespace std;
#define MAX 1001

char A[MAX];
char B[MAX];
int SUM[MAX];
void Add(char * op1, char * op2); //加法

int main()
{
int T;
cin >> T;
int k = 0;

while (T--)
{
cin >> A >> B;
cout << "Case " << ++k << ":"<<endl;
int len1 = strlen(A);
int len2 = strlen(B);
for (int i = 0; i < len1; i++)
cout << A[i];
cout << " + ";
for (int j = 0; j < len2; j++)
cout << B[j];
cout << " = ";
Add(A, B);
if (T) //最后一个不输出换行,一开始我没有这一步,所以看了很久才看出来的
cout << endl;
}
}
void Add(char * op1, char * op2) //加法
{
memset(SUM, 0, sizeof(op1));
int len1 = strlen(op1);
int len2 = strlen(op2);
int dif;
if (len1 > len2) //把这两个数成同样长度的.
{
dif = len1 - len2;
for (int i = len1; i >= dif;)
op2[i--] = op2[len2--];
for (int i = 0; i < dif; i++)
op2[i] = '0';
}
else if (len1 < len2)
{
dif = len2 - len1;
for (int i = len2; i >= dif;)
op1[i--] = op1[len1--];
for (int i = 0; i < dif; i++)
op1[i] = '0';
} //这里结束,两个数组已经补全了
//cout << '\n'<<op1 << '\n' << op2 << endl;
//cout <<endl<<strlen(op1) << "这是长度" << strlen(op2) << endl;
int carry = 0;
int temp, digit = 0;
len1 = strlen(op1); //这里要从新算一下,一开始我没有算,所以 当 前面数长度小于后面长度时,就会错
//len2 = strlen(op2);

for (int i = len1 - 1; i >= 0; i--) //开始计算,
{
temp = (op1[i] - '0') + (op2[i] - '0') + carry; //一位一位的相加,并加上进位
SUM[digit] = temp % 10;
carry = temp / 10; //更新进位
digit++;
}
if (carry) //处理最后一位的进位
{
SUM[digit] = carry;
digit++;
carry /= 10;
}
for (int i = digit - 1; i >= 0; i--) //输出
cout << SUM[i];
cout << endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值