POJ TOYS

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

题目大意:

给你一个矩形(已知左上角和右下角坐标)和n个“边界”(可理解为线段,线段两端点分别在矩形上边界和下边界上),这些“边界”将矩形分成0~n个格子(从左到右)。同时给出m个点,计算每个格子中的有多少个点?

    输入包含多组数据,以输入一个0结束。
    每组数据第一行有6个整数,n,m,x1,y1,x2,y2,分别表示有n条边界,m个点,矩形左上角坐标(x1,y1 ),矩形右下角坐标(x2,y2)。
    接下来n行,分别输入两个整数a,b,表示一条“边界”(a,y1)(b,y2)。
    接下来m行,分别输入两个整数a,b,表示一个点(a,b)。

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

输出格式见样例

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题解

这道题蛮水的,也是当模板吧,我的方法是二分+叉积判断,注意:如果toy再一个边界i上(0<=i<=n)它属于第i个格子。具体见代码:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
using namespace std;
int n,m,xs,ys,xx,yx,zz;
int count[5005];
struct dian
{int x,y;} ds[5002],dx[5002];//分别表示上边的点和下边的点 
int area(int w,int s,int t)//叉积求面积 
{
	int ax=ds[w].x-dx[w].x,ay=ds[w].y-dx[w].y,
	    bx=s-dx[w].x, by=t-dx[w].y;
	return ax*by-ay*bx;
}
void doit(int s,int t)
{
	int mid,l=0,r=n+1;
	while(l<=r)
	   {mid=(l+r)>>1;
	    int s1=area(mid,s,t),s2=area(mid+1,s,t);
	    if(s1<=0&&s2>0) {count[mid]++; break;}
	    else if(s2==0) {count[mid+1]++; break;}
	    else if(s1>0) r=mid;
	    else
		   {l=mid+1;
		    //if(l==n) {count[n]++; break;}
		   }
	   }
}
void init()
{
	scanf("%d%d%d%d%d",&m,&xs,&ys,&xx,&yx);
	zz=0;
	for(int i=1;i<=n;i++)
	   {int a,b;
		scanf("%d%d",&a,&b);
	    ds[i].x=a,ds[i].y=ys; dx[i].x=b,dx[i].y=yx;//插入“边界 ” 
	   }
	ds[0].x=xs,ds[0].y=ys; dx[0].x=xs,dx[0].y=yx;
	ds[n+1].x=xx,ds[n+1].y=ys; dx[n+1].x=xx,dx[n+1].y=yx;
	//for(int i=0;i<=n+1;i++) printf("%d %d %d %d\n",ds[i].x,ds[i].y,dx[i].x,dx[i].y);
	memset(count,0,sizeof(count));//初始化计数 
	for(int i=1;i<=m;i++)
	   {int a,b;
		scanf("%d%d",&a,&b);
		doit(a,b);
	   }
}
int main()
{
	while(scanf("%d",&n)&&n)
	   {init();
	    for(int i=0;i<=n;i++)
	       printf("%d: %d\n",i,count[i]);
	    printf("\n");
	   }
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值