Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
题目大意
有N只牛,M场比赛的结果,“a b”表示a打败了b。问有多少只牛的排名可以确定。
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
题解
闭包传递。(很多人都这么说)其实就是floyd。A打败B则连一条从A到B的单向边,一个点前后若共有n-1个点,则它的名次是确定的。(不能只算每个点前面的点,在从大到小数,这样会wa。)
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m,a[102],ans=0;
bool map[102][102];
void floyd()
{
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{if(map[i][k]&&map[k][j]) map[i][j]=1;}
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=1;i<=m;i++)
{int x,y;
scanf("%d%d",&x,&y);
map[x][y]=1;
}
floyd();
for(int i=1;i<=n;i++)
{int p=0;
for(int j=1;j<=n;j++) p=p+map[i][j]+map[j][i];
if(p==n-1) ans++;
}
printf("%d",ans);
return 0;
}