BZOJ 1636: [Usaco2007 Jan]Balanced Lineup

Description

For the daily milking, Farmer John's N cows (1 <= N <= 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height. Farmer John has made a list of Q (1 <= Q <= 200,000) potential groups of cows and their heights (1 <= height <= 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

* Line 1: Two space-separated integers, N and Q. * Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i * Lines N+2..N+Q+1: Two integers A and B (1 <= A <= B <= N), representing the range of cows from A to B inclusive.

题目大意:

给出一段长度为n(1 <= N <= 50,000)的数列,每个数字a(1 <= a<= 1,000,000),q(1 <= Q <= 200,000) 个询问,询问[l,r]之间的“最大值-最小值”。

第一行为n和q,第二行n个数表示ai,接下来q行行一对l,r。

Output

* Lines 1..Q: Each line contains a single integer that is a response
to a reply and indicates the difference in height between the
tallest and shortest cow in the range.

Sample Input

6 3
1 7 3 4 2 5
1 5
4 6
2 2

Sample Output

6
3
0

题解

线段树水题。

#include<cstdio> 
#include<cstring> 
#include<iostream> 
#include<algorithm> 
#include<cstdlib> 
#include<cmath> 
using namespace std; 
int n,m,a[50002]; 
struct shu {int l,r,mx,mn;} tr[200002]; 
void build(int w,int b,int e) 
{ 
    tr[w].l=b; tr[w].r=e; 
    if(b==e) {tr[w].mx=tr[w].mn=a[b]; return;} 
    int mid=(b+e)>>1; 
    build(w<<1,b,mid); build((w<<1)+1,mid+1,e); 
    tr[w].mx=max(tr[w<<1].mx,tr[(w<<1)+1].mx); 
    tr[w].mn=min(tr[w<<1].mn,tr[(w<<1)+1].mn); 
} 
int askmx(int w,int b,int e) 
{ 
    int l=tr[w].l,r=tr[w].r,mid; 
    if(l==b&&r==e) return tr[w].mx; 
    mid=(l+r)>>1; 
    if(mid>=e) return askmx(w<<1,b,e); 
    else if(mid<b) return askmx((w<<1)+1,b,e); 
    else return max(askmx(w<<1,b,mid),askmx((w<<1)+1,mid+1,e)); 
} 
int askmn(int w,int b,int e) 
{ 
    int l=tr[w].l,r=tr[w].r,mid; 
    if(l==b&&r==e) return tr[w].mn; 
    mid=(l+r)>>1; 
    if(mid>=e) return askmn(w<<1,b,e); 
    else if(mid<b) return askmn((w<<1)+1,b,e); 
    else return min(askmn(w<<1,b,mid),askmn((w<<1)+1,mid+1,e)); 
} 
int main() 
{ 
    scanf("%d%d",&n,&m); 
    int i,x,y; 
    for(i=1;i<=n;i++) scanf("%d",&a[i]); 
    build(1,1,n); 
    for(i=1;i<=m;i++) 
       {scanf("%d%d",&x,&y); 
        printf("%d\n",askmx(1,x,y)-askmn(1,x,y)); 
       } 
    return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值