sicily 1003. 统计各种字符的数量

Description

输入一行文字,找出大写字母,小写字母,空格,数字以及其他字符的数量

Input

SYSU hello 123 ???

Output

uppercase:4
lowercase:5
number:3
blank:3
others:3

 

Sample Input
 Copy sample input to clipboard
SYSU hello 123 ???
Sample Output
uppercase:4
lowercase:5
number:3
blank:3
others:3

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
char a[101];

int main()
{
 gets(a);
 int n=strlen(a);
 int f=0;
 int b=0;
 int c=0;
 int d=0;
 int e=0;
 for(int i=0;i<n;i++)
 {
  if((a[i]<='Z')&&(a[i]>='A')) f++;
  if((a[i]<='z')&&(a[i]>='a'))  b++;
  if(a[i]==' ') c++;
  if((a[i]>='0')&&(a[i]<='9')) d++;
  else continue;
 }
 e=n-f-b-c-d;
 cout<<"uppercase:"<<f<<endl;
 cout<<"lowercase:"<<b<<endl;
 cout<<"number:"<<c<<endl;
 cout<<"blank:"<<d<<endl;
 cout<<"others:"<<e;
 
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值