ZOJ 3758

36 篇文章 0 订阅
11 篇文章 0 订阅

Singles' Day(or One's Day), an unofficial holiday in China, is a pop culture entertaining holiday on November 11 for young Chinese to celebrate their bachelor life. With the meaning of single or bachelor of number '1' and the huge population of young single man. This festival is very popular among young Chinese people. And many Young bachelors organize parties and Karaoke to meet new friends or to try their fortunes that day.

On Singles' Day, a supermarket has a promotional activity. Each customer will get a ticket on which there are two integers b and N, representing an integer M that only contains N digits 1 using b as the radix. And if the number M is a prime number, you will get a gift from the supermarket.

Since there are so many customers, the supermarket manager needs your help.

Input
There are multiple test cases. Each line has two integers b and N indicating the integer M, which might be very large. (2 >= b >= 16, 1 >= N >= 16)

Output
If the customer can get a gift, output "YES", otherwise "NO".

Sample Input
3 3
2 4
2 1
10 2

Sample Output
YES
NO
NO
YES

Hint
For the first sample, b=3, N=3, so M=(111)3, which is 13 in decimal. And since 13 is a prime number, the customer can get a gift, you should output "YES" on a line.

#include<string.h>
#include<stdio.h>
#include<algorithm>
bool prim(int n){
	if(n==1){
		return false;
	}
	for(int i=2; i*i<=n; i++)
		if(n%i == 0)
			return false;
	return true;
}

int main()
{
    int mul,i,b,N,sum;//b进制,N个1 
    scanf("%d%d",&b,&N);
    sum = 1;
    mul = 1;
    for(i=1;i<N;i++){
    	mul *= b; 
    	sum += mul;
	}
	if(prim(sum)){
		printf("YES\n");
	} else{
		printf("NO\n");
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值