HDOJ 1312 (POJ 1979) Red and Black

4 篇文章 0 订阅
3 篇文章 0 订阅

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23956    Accepted Submission(s): 14495

 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

 

 

Sample Output

45

59

6

13

 

一个人站在一块黑色瓷砖上,他只能前后左右的走,切不可以走到红色瓷砖上。

在一个H*W矩形房间中,当前位置为 @ 点。他只能沿上下左右4个方向走,且只能走 ‘. ’点,不能走‘ # ’点,已走过的 ‘. ’点可重复走,问他最多可走多少 ‘. ’点。
        由于已走过的 . 点可重复走,故可考虑无回溯DFS,将走过的 . 点标记为 #,这样可避免设置vis数组。求它可到达的瓷砖数。

#include<string.h>
#include<stdio.h>
#include<algorithm>
#define N 20
int n,m;
char map[N][N];
bool have[N][N];
int count,trueRow,trueCol; 
void bfs(int row, int col){
	if(row < n && row >= 0 && col < m && col>=0){//越界 
		if((map[row][col] == '.' || map[row][col] == '@' ) && have[row][col] == false){
			have[row][col] = true;//开始的时候没把’@‘加上,盲区了吧 
			count++;		//计数 
			bfs(row-1,col);//上下左右遍历 
			bfs(row,col+1);
			bfs(row+1,col);
			bfs(row,col-1);
		}
	} 
}

int main()
{
    int i,j;
	scanf("%d%d",&m,&n);
	getchar(); //输入n之后的换行符 
	memset(have,false,sizeof(have));
    for(i=0; i<n; i++){
    	for(j=0; j<m; j++){
    		scanf("%c", &map[i][j]); 
			if(map[i][j] == '@'){//确定开始位置 
				trueRow = i;
				trueCol = j;
			}    		
		}
		getchar();//输入一行之后的换行符   	
	}
	count = 0;//全局的能联通的个数 
	bfs(trueRow, trueCol);//宽度优先遍历 
	printf("%d\n",count);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值