杭电 2680

36 篇文章 0 订阅
21 篇文章 0 订阅

                                Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21920    Accepted Submission(s): 6998

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5

1 2 2

1 5 3

1 3 4

2 4 7

2 5 6

2 3 5

3 5 1

4 5 1

2

2 3

4 3 4

1 2 3

1 3 4

2 3 2

1

1

Sample Output

1

-1

常规的dijkstra做不行,要改变一下,把终点当起点反向构图

一直超时,还没解决

#include<iostream>
#include<iomanip>
#include<algorithm> 
#include<cstring>
#include<sstream> 
#include<cmath>
#define undef 0x3f3f3f3f
#define NUM 1101
using namespace std;
int cityLen[NUM][NUM];
int n,endCity,w;
int dis[NUM],start[NUM];
int dijkstra(int begin){
	int visit[NUM],nowMinLen,minCity,ans;
	ans=undef;
	memset(dis, undef, sizeof(dis));
	dis[begin]=0;
	for(int i=1; i<=n; i++)
		dis[i]=cityLen[i][begin];
	memset(visit, 0, sizeof(visit));
	visit[begin]=1;
	for(int i=1; i<n; i++){
		nowMinLen=undef;
		minCity=-1;
		for(int j=1; j<=n; j++)
			if(visit[j]==0 && nowMinLen>dis[j]){
				nowMinLen=dis[j];
				minCity=j;
			}
		if(minCity==-1)
			break;
		visit[minCity]=1;
		for(int j=1; j<=n; j++){
			if(visit[j]==0 && dis[j]>dis[minCity]+cityLen[j][minCity])
				dis[j]=dis[minCity]+cityLen[j][minCity];
		}
	}
	for(int i=0; i<w; i++)
		if(ans>dis[start[i]])
			ans=dis[start[i]];
	return ans;
}
int main()
{
	int m,p,q,t,minLen,temp;
	//while(cin>>n>>m>>endCity){
	while(scanf("%d%d%d",&n,&m,&endCity)!=EOF){
		minLen=undef;
		memset(cityLen,undef,sizeof(cityLen));
		for(int i=1; i<=n; i++)
			cityLen[i][i]=0;
		for(int i=1; i<=m; i++){
			//cin >> p >> q >> t;
			scanf("%d%d%d",&p,&q,&t);
			if(cityLen[p][q]>t){
				cityLen[p][q]=t;//正常输入,遍历的时候反着来 
			}
		}
		cin>>w;
		for(int i=0; i<w; i++){
			scanf("%d",&start[i]);
			minLen=dijkstra(endCity);    
		}
		if(minLen==undef){
			//cout << -1 << endl;
			printf("-1\n");
		} else{
			printf("%d\n",minLen);
//			cout << minLen << endl;
		}
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值