杭电 1016

21 篇文章 0 订阅
2 篇文章 0 订阅

                                 Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74401    Accepted Submission(s): 31616

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

Sample Input

6

8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

还没AC:格式问题,多打印问题

#include<iostream>
#include<iomanip>
#include<algorithm> 
#include<cstring>
#include<sstream> 
#include<cmath>
#define NUM 22
using namespace std;
int isPrime(int n){
	double judge=sqrt(n);
	if(n==1)
		return 0;
	for(int i=2; i<=judge; i++)
		if(n%i==0)
			return 0;
	return 1;
}
int prime[NUM],n,caseNum;
int isVisit(int num, int index){
	for(int i=0; i<index; i++)
		if(prime[i]==num)
			return 1;
	return 0;
}
void primeRecur(int now){
	if(now == n){
		//print
		cout << "Case " << caseNum << ":" << endl;
		cout << prime[0];
		for(int i=1; i<n; i++)
			cout << " " << prime[i];
		cout << endl;
		cout << prime[0];
		for(int i=n-1; i>0; i--)
			cout << " " << prime[i];
		cout << endl;
		return;
	}
	for(int i=2; i<=n; i++){
		if(isVisit(i, now)==0){
			if(now<n-1 && isPrime(prime[now-1]+i)){
				prime[now]=i;
				primeRecur(now+1);
			}else if(now==n-1 && isPrime(prime[now-1]+i) && isPrime(prime[0]+i)){
				prime[now]=i;
				primeRecur(now+1);
			}
		}	
	}
	return;
}
int main()
{
	int now;
	caseNum=0;
	while(cin>>n){
		caseNum++;
		prime[0]=1;
		primeRecur(1);
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值