ZOJ 1828 Fibonacci Numbers

 

Fibonacci Numbers

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.


Sample Input

100


Sample Output

354224848179261915075


Note:

No generated Fibonacci number in excess of 1000 digits will be in the test data, i.e. f(20) = 6765 has 4 digits.

 

这个题是关于斐波拉契数列的大数加法。一直以为斐波拉契只是     f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)  后来在图书馆看到一本书叫斐波拉契数列,我就惊讶了!安静

有兴趣的童鞋可以去看看,不知道你能不能看懂,反正我是看不懂。

 

 

大数的处理有多种办法:一种是用字符串转换成整数一位一位的加;还有一种是用整形数组,根据题目的不同要求选择合适方法,比如这道题斐波那契数列,给出的是n,让你求第n项,我们可以用二维数组,fb[n][k]的值就是第n项第k位的数是多少这里可以直接用memcpy()函数,算的时候可以直接把后一项叠加到前一项上面,这样就不用计算时候用两项相加了。关于memcpy()函数,可以参看360百科,讲得很详细,本想转过来的又觉得麻烦鄙视

 

AC的代码(睡觉):

 

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <string.h>
using namespace std;
int fb[6001][1003];
int main()
{
    int len[6002];
    int n,i,j;
    memset(fb,0,sizeof(fb));
    fb[1][0]=fb[2][0]=1;
    len[1]=len[2]=1;
    for(i=3;i<=6000;i++)
    {
       memcpy(fb[i],fb[i-1],sizeof(fb[i-1])); //直接把第一项的值赋值到当前所求项上 
       for(j=0;j<len[i-2];j++)//与以往的大数加法有少许不同
       {
       fb[i][j]+=fb[i-2][j];
       }
       for(j=0;j<max(len[i-1],len[i-2]);j++)
       {
           if(fb[i][j]>9)fb[i][j+1]+=fb[i][j]/10;
           fb[i][j]%=10;
       }
       if(fb[i][j]!=0)
       {
       j++;
       }
       len[i]=j;
    }    
       while(cin>>n)
       {
           for(int k=len[n]-1;k>=0;k--)
           {
           cout<<fb[n][k];
           }
           cout<<endl;
       }
   return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值