ZOJ 1828 Fibonacci Numbers

Fibonacci Numbers

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.


Sample Input

100


Sample Output

354224848179261915075


Note:

No generated Fibonacci number in excess of 1000 digits will be in the test data, i.e. f(20) = 6765 has 4 digits.


分析:数据太大,模拟大数加法

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int f[5005][1010];		//保存最终结果  
int len[5005];			//保存最终结果的长度  

void display()
{
	f[1][1] = 1;
	f[2][1] = 1;
	len[1] = 1;
	len[2] = 1;
	int i, j;
	for (i = 3; i <= 5000; i++)
	{
		int jin = 0;	//判断是否有进位  
		for (j = 1; j <= max(len[i - 1] , len[i - 2]) ; j++)
		{
			f[i][j] = f[i - 1][j] + f[i - 2][j] + jin;
			jin = f[i][j] / 10;
			f[i][j] %= 10;
		}
		if (jin)
		{
			f[i][j] = 1;
			len[i] = j;
		}
		else 
		{
			len[i] = j - 1;
		}
	}
}
int main()
{
	display();
	int n;
	while (~scanf("%d", &n))
	{
		for (int i = len[n]; i >= 1; i--)
			printf("%d", f[n][i]);
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值