hdu 1709 The Balance

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1709

 

Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5 参考大神的解法,01背包。。。 代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<map>
#include<stack>
#include<queue>
#define max(x,y)x>y?x:y
#define min(x,y)x<y?x:y
using namespace std;
const int maxn=105;
const int maxm=10005;
int a[maxm];
int dp[maxm],vis[maxm];
int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(dp,0,sizeof(dp));
        int sum=0;
        vis[0]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        for(int i=1;i<=n;i++)
        {
            memset(dp,0,sizeof(dp));
            for(int j=0;j<=sum;j++)
            {
                if(vis[j])
                {
                    dp[j+a[i]]=1;
                    dp[abs(j-a[i])]=1;
                }
            }
            for(int j=0;j<=sum;j++)
                if(dp[j])
                vis[j]=1;
        }
        int cnt=0;
        for(int i=1;i<=sum;i++)
            if(!vis[i])
                cnt++;
        printf("%d\n",cnt);
        int first=0;
        for(int i=1;i<=sum;i++)
        {
            if(!vis[i])
            {
                if(!first)
                    {
                        printf("%d",i);
                        first=1;
                    }
                else
                    printf(" %d",i);
            }
        }
        if(cnt)
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值