pojn 1861 Network(Kruskal)

题目链接:http://poj.org/problem?id=1861

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion


题意是求最小生成树中的最大边长,并输出生成树的边。Sample有问题。。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1005;
const int inf=1<<31-1;
struct node
{
    int u,v;
    int cost;
}E[maxn*maxn];
int f[maxn];
int cnt;
int ret[maxn];
int cmp(node a,node b)
{
    return a.cost<b.cost;
}
int find(int x)
{
    if(f[x]!=x)
        f[x]=find(f[x]);
    return f[x];
}
int kruskal(int ne)
{
    int maxcost=0;
    cnt=0;
    for(int i=0;i<ne;i++)
    {
        int f1=find(E[i].u);
        int f2=find(E[i].v);
        if(f1!=f2)
        {
            ret[cnt++]=i;
            f[f1]=f2;
            maxcost=max(maxcost,E[i].cost);
        }
    }
    return maxcost;
}
int n,m;
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)==2)
    {
        memset(ret,0,sizeof(ret));
        for(int i=0;i<=n;i++)
            f[i]=i;
        for(int i=0;i<m;i++)
            scanf("%d %d %d",&E[i].u,&E[i].v,&E[i].cost);
        sort(E,E+m,cmp);
        int ans=kruskal(m);
        printf("%d\n",ans);
        printf("%d\n",cnt);
        for(int i=0;i<cnt;i++)
            printf("%d %d\n",E[ret[i]].u,E[ret[i]].v);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Kruskal算法是一种用来求加权连通图的最小生成树(MST)的算法,由Joseph Kruskal在1956年发表。该算法的基本思想是按照边的权值从小到大的顺序选择边,并保证这些边不构成回路。具体做法是首先构造一个只含有n个顶点的森林,然后依据权值从小到大从连通网中选择边加入到森林中,并保证森林中不产生回路,直至森林变成一棵树为止。 使用Kruskal算法求解最小生成树的过程主要有两个关键步骤。首先,需要对图的所有边按照权值大小进行排序。其次,需要判断在将边添加到最小生成树中时是否会形成回路。通过这两个步骤,Kruskal算法能够找到图的最小生成树。 总结来说,Kruskal算法通过按照边的权值从小到大选择边,并保证不形成回路的方式来构建最小生成树。这种算法适用于解决求解加权连通图的最小生成树问题。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [Kruskal算法简易教程(附最全注释代码实现)](https://blog.csdn.net/hzf0701/article/details/107933639)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [克鲁斯卡尔算法(Kruskal)详解](https://blog.csdn.net/weixin_45829957/article/details/108001882)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值