poj 3273 Monthly Expense (二分最小化最大值)

题目链接:http://poj.org/problem?id=3273


Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

USACO 2007 March Silver


题意:n个数的序列,划分为m段,使其最大的一段的和最小。。
思路:二分。。注意解的范围。。

代码:
#include <algorithm>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cmath>
#include <stack>
#include <queue>
#include <list>
#include <map>
#include <set>

using namespace std;

#define clr(x, y)      memset(x, y, sizeof(x))
#define fr(i,n)        for(int i = 0; i < n; i++)
#define fr1(i,n)       for(int i = 1; i <= n; i++)
#define upfr(i,j,n)    for(int i = j; i <= n; i++)
#define dowfr(i,j,n)   for(int i = n; i >= j; i--)
#define scf(n)         scanf("%d", &n)
#define scf2(n,m)      scanf("%d %d",&n,&m)
#define scf3(n,m,p)    scanf("%d %d %d",&n,&m,&p)
#define ptf(n)         printf("%d",n)
#define ptf64(n)       printf("%I64d",n)
#define ptfs(s)        printf("%s",s)
#define ptln()         printf("\n")
#define ptk()          printf(" ")
#define ptc(c)         printf("%c",c)
#define srt(a,n)       sort(a,n)
#define LL long long
#define pi acos(-1.0)
#define eps 0.00001
#define maxn 100005
#define mod 1000000007
#define inf 1000000000

int a[maxn];
int n,m;

int C(int d)
{
	int cnt = 0, la = 0;
	fr(i, n)
	{
		if(a[i] + la > d)  //如果加和比当前的最大值还大,继续往后找,同时cnt++
		{
			cnt++;
			la = a[i];
		}
		else
			la += a[i];  //否则进行加和
	}
	cnt++;
	if(cnt > m)               //如果总的段大于m,则不满足
		return 0;
	return 1;
}

int main()
{
	// freopen("in.txt","r",stdin);
	while(scf2(n,m) == 2)
	{
		int lb = 0, ub  = 0;    //解的范围是max(a[i])~sum(a[i])
		fr(i, n)
		{
			scf(a[i]);
			ub += a[i];
			if(a[i] > lb)
				lb = a[i];
		}
		while(lb < ub)
		{
			int mid = (lb + ub) / 2;
			if(C(mid))
			    ub = mid;
			else
			    lb = mid + 1;
		}
		printf("%d\n", lb);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值