map的使用&实现不同单词的计数器

Sample input:
3//所要计数的单词的最小长度
abc 123  abc iie I hate  TA //一个句子

Sample output:

2
7         
4


代码:

//main.cpp


    #include <iostream>
    #include <cstdio>
    #include <string>
    #include "WordsCounter.h"
    using namespace std;
     
    int main() {
    WordsCounter wordsCounter(5);
    cout << wordsCounter("It is so interesting that I like it greatly") << endl;
     
    string text = "it is so interesing that I like it greatly";
    wordsCounter.setBound(2);
    cout << wordsCounter(text) << endl;
     
    int n;
    cin >> n;
    getchar(); // get the enter
    getline(cin, text);
    wordsCounter.setBound(n);
    cout << wordsCounter(text) << endl;
     
    return 0;
    }
     


//WordsCounter.h


#ifndef WORD_H
#define WORD_H
#include<set>
#include<iostream>
using namespace std;

class WordsCounter {
  public:
    WordsCounter() {}
    explicit WordsCounter(int len):length(len) {}
    int operator()(string str) {
        set<string> strset;
        int i;
        string tmp;
        for (i = 0; i < str.size(); i++) {
            while (str[i] == ' ') i++;
            while (str[i] != ' ' && i < str.size()) {
                tmp.push_back(str[i]);
                i++;
            }
            if (!tmp.empty() && tmp.size() >= length)
               strset.insert(tmp);
               tmp.clear();
        }
        return strset.size();
    }
    void setBound(int len) {length = len;}
  private:
    int length;
};

#endif


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值