10-4. 字符串循环左移(20)

输入一个字符串和一个非负整数N,要求将字符串循环左移N次。

输入格式:

输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。

输出格式:

在一行中输出循环左移N次后的字符串。

输入样例:
Hello World!
2
输出样例:
llo World!He
#include <stdio.h>
#include <string.h>

int main(int argc, char *argv[])
{
	char test[101] = {0};
	gets(test);
	int count;
	scanf("%d", &count);
	char ch;
	int i, j;
	char *s = test;
	int len = strlen(test) - 1;
	for (i = 0; i < count; i++) {
		s = test;
		ch = *test;
		for (j = 0; j < len; j++) {
			*s = *(s + 1);
			s++;
		}
		*s = ch;
	}
	printf("%s\n", test);

	return 0;
}

还有个很简单的方法

#include <stdio.h>
#include <string.h>

int main(int argc, char *argv[])
{
	char test[101] = {0};
	gets(test);
	int count;
	scanf("%d", &count);
	char *s = test;
	int len = strlen(test);
	if (count >= len)
		count %= len;

	s = test + count;
	printf("%s", s);
	*s = '\0';
	printf("%s\n", test);

	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值