Linux Qt5 开发环境搭建


  
1、下载 Qt5 离线安装包

下载地址:http://www.qt.io/download-open-source/ 
进入后,请注意页面最下方有个【View All Downloads】链接,点击它可找到离线安装包! 
这里写图片描述

根据自己的操作系统版本,选择对应的安装包: 
这里写图片描述

  
  
2、添加执行权限

下载完成后,得到离线安装包,打开【终端】,进入离线安装包所在的目录,然后执行命令:

sudo chmod +x qt-opensource-linux-x86-5.4.1.run
  • 1

这里写图片描述

  
  
3、开始安装

添加执行权限后,可以开始安装Qt5,在步骤2的基础上,继续运行命令:

sudo ./qt-opensource-linux-x86-5.4.1.run
  • 1

可见如下窗口: 
这里写图片描述

接下来按照编号指示的步骤依次操作: 
这里写图片描述

这里写图片描述

这里写图片描述

这里写图片描述

这里写图片描述

  
  
4、配置环境变量

在【终端】中执行如下命令:

sudo gedit /etc/profile
  • 1

添加如下内容: 
32位系统:

export QTDIR=/opt/Qt5.4.1/5.4
export PATH=$QTDIR/gcc/bin:$PATH
export LD_LIBRARY_PATH=$QTDIR/gcc/lib:$LD_LIBRARY_PATH
  • 1
  • 2
  • 3

64位系统:

export QTDIR=/opt/Qt5.4.1/5.4
export PATH=$QTDIR/gcc_64/bin:$PATH
export LD_LIBRARY_PATH=$QTDIR/gcc_64/lib:$LD_LIBRARY_PATH
  • 1
  • 2
  • 3

上面的路径,请自己对照所安装的版本更改!

保存退出, 
执行命令:source /etc/profile 
让环境变量生效!

  
  
5、验证是否安装成功

终端下执行命令:qmake -version

如果出现如下信息,表示配置安装成功:

这里写图片描述

  
  
6、测试实例

打开Qt Creator,点击New Project,创建一个新项目:

这里写图片描述

这里写图片描述

这里写图片描述

这里写图片描述

这里写图片描述

这里写图片描述

  
  
7、解决错误

当尝试运行时,会有错误出现:

这里写图片描述

根据错误提示,我们打开如下的界面:

这里写图片描述

这里写图片描述

出现上述错误是因为我们没有安装可用的g++编译器(基本上所有的linux发行版都自带安装了gcc编译器),在终端中执行如下命令:

sudo apt-get install g++
  • 1

安装完成后,重新打开Qt Creator,可以发现已经找到编译器了:

这里写图片描述

再编译一次: 
这里写图片描述

会发现报如下的错误: 
这里写图片描述

这是因为没有安装GL库,终端下执行命令:

sudo apt-get install libgl1-mesa-dev
  • 1

安装完成后,再次编译,应该就能成功了!

  
  
8、安装完成 
经过上面的步骤,应该能成功编译并运行程序了,整个安装过程结束!

这里写图片描述

展开阅读全文

没有更多推荐了,返回首页