HDU 1074 Doing Homework(状态压缩 + DP)

Problem Description:

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input:

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output:

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input:

2

3

Computer 3

English 20 1

Math 3 2

3

Computer 3 3

English 6 3

Math 6 3

Sample Output:

2

Computer

Math

English

3

Computer

English

Math

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#define LL long long
using namespace std;
const int MAXN = 16;
const int inf = 0x3f3f3f3f;
struct Node
{
    char name[20];
    int D, C;
}node[MAXN];
int dp[1<<MAXN];
int pre[1<<MAXN];
int n;
void output(int status)//按字典序输出(题目输入顺序即是字典序)
{
    if(status == 0) return ;
    int t = 0;
    for(int i=0;i<n;i++)
    {
        if((status & (1<<i)) != 0 && (pre[status] & (1<<i)) == 0)
        {
            t = i;
            break;
        }
    }
    output(pre[status]);
    printf("%s\n", node[t].name);
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i=0;i<n;i++)
        {
            scanf("%s%d%d", &node[i].name, &node[i].D, &node[i].C);
        }
        for(int i=0;i<(1<<n);i++) dp[i] = inf;
        dp[0] = 0;//初始化
        for(int i=0;i<(1<<n);i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i & (1<<j)) continue;//如果该作业已经完成则继续
                int time = 0;
                for(int k=0;k<n;k++) if(i & (1<<k))
                    time += node[k].C;
                time += node[j].C;//统计直到完成该作业所需的总时间
                if(time > node[j].D) time -= node[j].D;
                else time = 0;
                if(dp[i|(1<<j)] > dp[i] + time)
                   {
                       dp[i|(1<<j)] = dp[i] + time;
                       pre[i|(1<<j)] = i;
                   }
            }
        }
        printf("%d\n", dp[(1<<n)-1]);
        output((1<<n)-1);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值