HDU 5301 Buildings(2015多校第二场)


Buildings

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 759    Accepted Submission(s): 210


Problem Description
Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building's sides.

The floor is represented in the ground plan as a large rectangle with dimensions  , where each apartment is a smaller rectangle with dimensions   located inside. For each apartment, its dimensions can be different from each other. The number   and   must be integers.

Additionally, the apartments must completely cover the floor without one   square located on  . The apartments must not intersect, but they can touch.

For this example, this is a sample of  .



To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

Your boss XXY wants to minimize the maximum areas of all apartments, now it's your turn to tell him the answer.
 

Input
There are at most   testcases.
For each testcase, only four space-separated integers,  .
 

Output
For each testcase, print only one interger, representing the answer.
 

Sample Input
      
      
2 3 2 2 3 3 1 1
 

Sample Output
      
      
1 2
Hint
Case 1 :
You can split the floor into five apartments. The answer is 1. Case 2:
You can split the floor into three apartments and two apartments. The answer is 2.
If you want to split the floor into eight apartments, it will be unacceptable because the apartment located on (2,2) can't have windows.
 

Source

解题思路:
如果没有不合法的块,那结果就是长和宽中最小值的一半,而,不合法的块所影响的只有它周围的四块,计算出这四块距离四个边的距离的最小值,就是添加上不合法块之后该块所需要的最长距离。需要注意特判一中情况,即不合法块在正中间的时候,并不造成影响。
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
int n, m, x, y;
int main()
{
    while(scanf("%d%d%d%d", &n, &m, &x, &y)!=EOF)
    {
        if(n == m && (n % 2 == 1 && m % 2 == 1) && (x == y && x == (n+1)/2))
        {
            cout << (n -1) / 2 << endl;
            continue;
        }
        int Min = min(n, m); int ans;
        if(Min & 1) ans = (Min + 1) / 2;
        else ans = Min / 2;
        int res = -10;
        int xx = x - 1, yy = y;
        if(xx >= 1 && yy >= 1) res = max(res, min(xx-1,min(yy-1,m-yy)));
        xx = x, yy = y-1;
        if(xx >= 1 && yy >= 1) res = max(res, min(min(xx-1,n-xx),yy-1));
        xx = x + 1, yy = y;
        if(xx <=n && yy >= 1) res = max(res, min(n-xx,min(yy-1,m-yy)));
         xx = x, yy = y+1;
        if(xx >= 1 && yy <= m) res = max(res, min(min(xx-1,n-xx),m-yy));
        res += 1;
        ans = max(ans, res);
        printf("%d\n", ans);
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值