POJ 3978(求素数)

知识点:
     1.求素数的test,从2~sqrt(n);
    
     2.如果数据很多,可以用素数表记录,然后sum=prime[m]-prime[n]求得!!!!!!!!!!!



                                                                                             Primes
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3204Accepted: 1245


Description

A pretty straight forward task, calculate the number of primes between 2 integers. 

Given 2 integers A ≤ B < 105 what’s the number of primes in range from A to B inclusive. 

Note: A prime number is a positive integer greater than 1 and is divisible by 1 and itself only. For N to be prime it is enough to test the divisibility of numbers less than or equal to square root of N.

Input

As many as 1000 lines, each line contains 2 integers A and B separated by a space. Input is terminated when A = B = -1 (Do not process this line).

Output

For every line in input – except for the last line where A = B = -1 - print the number of prime numbers between A and B inclusive.

Sample Input

0 9999
1 5
-1 -1

Sample Output

1229
3


#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

bool is_prime(int n)
{
    if(n<=0||n==1)                 //贡献1 WA,a,b可能小于0;so n<=0 return false;
        return false;
    for(int i=2;i<=sqrt((double)n);i++)
    {
        if(n%i==0)
            return false;
    }
    return true;
}

int main()
{
    int a,b;
    int sum;
    while(1)
    {
        sum=0;
        scanf("%d%d",&a,&b);
        if(a==-1&&b==-1)
            break;
        for(int i=a;i<=b;i++)
            if(is_prime(i))
                ++sum;
        printf("%d\n",sum);

    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值