poj-1363-rails

Description


There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 




The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 


Input


The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 


The last block consists of just one line containing 0.
Output


The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.
Sample Input


5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output


Yes
No


Yes


代码如下:这题很简单,我把思路都注释在了代码上了!

#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
int n,bs[2014];
int main()
{
    while(cin>>n,n)
    {
        while(cin>>bs[1],bs[1])
        {
            stack<int>Q;
            int flag=1;
            for(int i=2; i<=n; i++)
                cin>>bs[i];//输入从B车站出去的顺序!
            int A=1,B=1;
            while(B<=n)
            {
                if(A==bs[B])
                    A++,B++;//如果是一个一个进出站台的话!说明车厢直接出栈
                else if(!Q.empty()&&Q.top()==bs[B])//在A站的火车按某个顺序进站C之后,
                    //在C站的最后一个火车编号如果和当前在B站的第一个火车编号一样的话!就表明符合要求!出栈操作!
                    Q.pop(),B++;
                else if(A<=n)//开辟一个栈,按顺序存储当前比bs[i]小的车厢
                    Q.push(A++);
                else
                {
                    flag=0;
                    break;//都不符合的话,就.......
                }
            }
            printf("%s\n",flag?"Yes":"No");
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值