LA4255



Given a sequence of integers, a1a2,..., an , we define its sign matrix S such that, for 1$ \le$i$ \le$j$ \le$n , Sij = `` + " if ai +...+ aj > 0 ; Sij = `` - " if ai +...+ aj < 0 ; and Sij = ``0" otherwise.

For example, if (a1a2a3a4) = (- 1, 5, - 4, 2) , then its sign matrix S is a 4×4 matrix:


 1234
1-+0+
2 +++
3  --
4   +


We say that the sequence (-1, 5, -4, 2) generates the sign matrix. A sign matrix is valid if it can be generated by a sequence of integers.

Given a sequence of integers, it is easy to compute its sign matrix. This problem is about the opposite direction: Given a valid sign matrix, find a sequence of integers that generates the sign matrix. Note that two or more different sequences of integers can generate the same sign matrix. For example, the sequence (-2, 5, -3, 1) generates the same sign matrix as the sequence (-1,5, -4,2).

Write a program that, given a valid sign matrix, can find a sequence of integers that generates the sign matrix. You may assume that every integer in a sequence is between -10 and 10, both inclusive.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases Tis given in the first line of the input. Each test case consists of two lines. The first line contains an integer n (1$ \le$n$ \le$10) , where n is the length of a sequence of integers. The second line contains a string ofn(n + 1)/2 characters such that the first n characters correspond to the first row of the sign matrix, the next n - 1 characters to the second row, ... , and the last character to the n -th row.

Output 

Your program is to write to standard output. For each test case, output exactly one line containing a sequence of n integers which generates the sign matrix. If more than one sequence generates the sign matrix, you may output any one of them. Every integer in the sequence must be between -10 and 10, both inclusive.

Sample Input 

3 
4 
-+0++++--+ 
2 
+++ 
5 
++0+-+-+--+-+--

Sample Output 

-2 5 -3 1 
3 4 
1 2 -3 4 -5
 
 
分析:
1.首先将输入的字符串转化成符号矩阵maxtrix[][]
2.将符号矩阵转化成图graph[][],如果maxtrix[i][j] == '-',则用graph[j][i-1] = 1表示节点j到i-1有一条有向边;如果maxtrix[i][j] == '+',则用graph[i-1][j] = 1表示节点i-1到j有一条有向边;如果maxtrix[i][j] == '0',则无需在graph[][]中记录
3.如果从节点i到节点j有一条有向边则节点j的入度加一,用数组degree[]记录每个节点的入度
4.进行n+1次循环找出degree[]为0的点,比如找到了节点i的入度degree[i] = 0,如果找到了则把它的进行degree[i]--操作,然后将所有从节点i出发的边上的节点j的入度degree[j]--操作;
5.在确定数组B[]中元素值的时候,如果graph[first][second]为0则说明maxtrix[first+1][second] == '0',所以B[first] = B[second]
 
看了一下自己写的代码,好乱。这两天写这道题把自己的思绪都给整乱了.............orz
 
 
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 100 + 5;

int main()
{
    int T, n, len;
    char str[maxn];//暂时存取读入的字符串
    char maxtrix[15][15];
    bool graph[15][15];
    int degree[15];//用来存储每个节点的入度
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        scanf("%s", str);
        //len = n * (n + 1) / 2;

        int count = 0;
        memset(graph, false, sizeof(graph));//对graph赋初值
        memset(degree, 0, sizeof(degree));//对每个节点的入度进行赋值
        for(int i = 1; i <= n; i++)
        for(int j = i; j <= n; j++)
            maxtrix[i][j] = str[count++];//将字符转入到符号矩阵中


        for(int i = 1; i <= n; i++){//将字符数组中的信息转化到degree[]数组和graph[][]数组中
            for(int j = i; j <= n; j++){
                if(maxtrix[i][j] == '+'){
                    degree[j]++;
                    graph[i-1][j] = true;
                }else if(maxtrix[i][j] == '-'){
                    degree[i-1]++;
                    graph[j][i-1] = true;
                }
            }
        }

        int ans[15];    count = 0;
        for(int i = 0; i <= n; ){//循环一共有n+1次
            for(int j = 0; j <= n; j++){
                if(degree[j] == 0){//首先找到一个入度为0的节点
                    ans[count++] = j;   //printf("%d\n", j);
                    degree[j]--;    i++;
                    for(int m = 0; m <= n; m++){
                        if(graph[j][m]) degree[m]--;
                        //graph[j][m] = false;//将从这个点出发的所有的边都消除
                    }
                    /*for(int k = j+1; k <= n; k++){//找出和上面的节点相等的节点
                        if(maxtrix[j+1][k] == '0'){
                            ans[count++] = k;   //printf("%d\n", k);
                            degree[k]--;
                            i++;    maxtrix[j+1][k] = '+';
                            for(int m = 0; m <= n; m++){
                                if(graph[k][m]) degree[m]--;
                                //graph[k][m] = false;//将从这个点出发的所有的边都消除
                            }
                        }
                    }
                    */
                }
            }
        }


        int first = ans[0];
        int B[15];  B[first] = 0;
        for(int i = 1; i < count; i++){
            int second = ans[i];
            if(!graph[first][second])   B[second] = B[first];
            else B[second] = B[first] + 1;
            first = second;
        }//得到数组B[]

        int a[15];
        for(int i = 1; i <= n; i++)
            printf("%d ", B[i]-B[i-1]);
        printf("\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值