poj 1050 To the Max

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39768 Accepted: 21017

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001

【题意】

求子矩阵最大和

【思路】

二维的最大连续子序列和,二维转一维。分别求上边为第i行到下边为第j行的子矩阵,更新最大ans;

【代码】

<span style="font-size:14px;">#include<cstdio>
int sum[105][105];
int main()
{
    int n;
    for(int i=0;i<=100;i++)
        sum[0][i]=0;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                int v;
                scanf("%d",&v);
                sum[i][j]=sum[i-1][j]+v;
            }
        }
        int ans=-1000;
        for(i=1;i<=n;i++)
        {
            for(j=i;j<=n;j++)//算上边为第i行到下边为第j行的子矩阵的最大和。
            {
                //printf("i=%d j=%d\n",i,j);
                int s=sum[j][1]-sum[i-1][1];
                ans=ans>s?ans:s;
                //printf("%d ",ans);
                for(int k=2;k<=n;k++)
                {
                    s=sum[j][k]-sum[i-1][k]+(s>0?s:0);
                    ans=ans>s?ans:s;
                  //  printf("%d ",ans);
                }
            //    printf("\n");
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值